Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Monitor
eesahe
post Jan 7 2005, 06:48 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 7-January 05
Member No.: 4,450



Hello,

I'm kinda new to Linux. I decided to try out Red Hat 9, but my monitor got "out of scan range" when I tried to install it in graphical mode. Well, I installed it in text mode but I can't get to X now. I did a quick google about the problem and found out that I could go to kernel and try to edit the file etc/X11/XF86Config. Well, lowering the rates and resolution didn't resolve the problem, and I renamed it and tried running redhat-config-xfree86 and redhat-config-xfree86 -reconfig, but still no help.

Any ideas what I could try? My monitor is Sony Multiscan E200. And sorry about the bad english :)
Go to the top of the page
 
+Quote Post
Robert83
post Jan 7 2005, 05:12 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hello,

first things first

check in the monitors manual the correct HorizSync and VerRefresh
and in your /etc/X11/XF86Config file search for something like this type in the proper values

Section "Monitor"
Identifier "Samsung"
HorizSync 31.5
VertRefresh 50-90
EndSection

also you can try vesa for a first run [b](but DO CHANGE THE ABOVE HZ'S TO CORRECT VALUES!!!!)[b/]

Section "Device"
Identifier "Matrox" ---> yours will be different change this to vesa
Driver "mga"
VideoRam 8192
BusID "PCI:0:12:0"
EndSection

then startx (and it should work without any problems)

if that works

then

cd /etc/
vi inittiab
and change that runlevel id something thingie to 5 instead of 3 you'll see that's right at the beggining

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
eesahe
post Jan 8 2005, 02:46 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 7-January 05
Member No.: 4,450



First, thank you about your response.

I edited the file etc/X11/XF86Config, and changed the "Monitor" and "Device" sections to these:

Section "Monitor"
Identifier "Trinitron"
HorizSync 30.0 - 85.0
VertRefresh 48.0 - 120.0
EndSection

Section "Device"
Identifier "Vesa"
Driver "mga"
VideoRam 8192
BusID "PCI:0:12:0"
EndSection



What should I write in the "Screen" section? Now it has these lines:

Section "Screen"
Identifier "Screen0"
Device "Vesa"
Monitor "Trinitron"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection


When I tried starting X, it crashed with an error log:

...
(EE) No devices detected

Fatal server error:
no screens found
...

Thanks in advance.

Edit: By the way, my graphics card is nVidia GeForce FX 5600. I remember that the installation worked a while ago when I had a different card (nVidia GeForce Ti4600). So, maybe it has something to do with my current graphics card?
Go to the top of the page
 
+Quote Post
hughesjr
post Jan 8 2005, 03:31 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



That card is way to new to use w/redhat 9 smile.gif

Is there a reason you want to install RH9 ... because it doesn't get security updates and unless you really need that distro, I recommend something else (Like FedoraCore3).

If you must install RH9, make sure to install the kernel-source rpm ... then at the command prompt from root use the command (this is all one line if it wraps ... with a space between wget and http):
CODE
wget http://download.nvidia.com/XFree86/Linux-x86/1.0-6629/NVIDIA-Linux-x86-1.0-6629-pkg1.run

then:

chmod 755 NVIDIA-Linux-x86-1.0-6629-pkg1.run

then after the driver compiles, edit XF86Config and change mga to nvidia for driver and remove the videoram and busid lines.

here is a readme

Pay particular attention to (sec-03) EDITING YOUR X CONFIG FILE of the readme and remove any lines that contain load dri or load GLcore and add load glx


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Jim
post Jan 8 2005, 03:32 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



You're going to have to install the NVIDIA module.

http://www.nvidia.com/object/linux_display...2_1.0-6629.html

Download the .run file read the README (README.txt) follow the read me instructions, and you should be a happy linux user.

If not, come back, and we will help you out.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
hughesjr
post Jan 8 2005, 03:35 PM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



dang JIM ... you are fast, but not as fast as me biggrin.gif


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
eesahe
post Jan 8 2005, 03:44 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 7-January 05
Member No.: 4,450



Hey guys, thanks about the fast answers!

I'll try to install that NVIDIA patch, but if RH9 is so old and unsupported, I think I'll try Fedora instead. I'll post later on when I have installed the patch smile.gif
Go to the top of the page
 
+Quote Post
eesahe
post Jan 8 2005, 03:56 PM
Post #8


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 7-January 05
Member No.: 4,450



Well, it seems like the network isn't configured properly, the command wget gave me an error: "Resolving download.nvidia.com... failed: Host not found". I'll just download Fedora Core 3 now and try again with it later tongue.gif

I guess I don't have to worry about uninstalling Red Hat? I can just choose the option "Install on a previous Linux partition" when installing Fedora?
Go to the top of the page
 
+Quote Post
Jim
post Jan 8 2005, 04:04 PM
Post #9


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



Fedora wont have it by default either. Because RedHat is based in America is has to pay NVIDIA to include thier drivers by default, even windows doesn't do this. Not that I am telling you not to switch, I think its a good idea regardless, but you are still going to have to get the package and install it.

Ya, Hughes, good to have you back, and its on now.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th October 2017 - 07:13 PM