Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Fat32 Permission Issues, Having an issue changing the permissions
tendonut
post Dec 5 2004, 07:41 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 9
Joined: 3-May 04
Member No.: 2,880



I am having an odd problem with changing the permissions on my FAT32 drive. After it has been mounted and everything, I can easily read everything in the drive, but I can't write if I am not logged on a root. I am basically trying to access that drive via my network from a Windows XP machine and the local permissions are what stand in my way. When I try to change the group permissions of the mounted drive in it's entirety, logged on a root, it says I don't have the permission to do so. I tried it both via the terminal and through GNOME, both with similar responses. The error I get when I try to write to the drive from the XP machine is "Access Denied". Can anyone help me?

This is what my smbusers file looks like

root = admin administrator
nobody = guest, smbguest
smbuser = name1 name2 name 3

I am a newbie btw, but does this mean if I log on with my XP machine as "name1" and use the smb password for "name1" that Linux thinks smbuser is logging on? (in a nutshell). What is odd, is even though "root" is the only user that has write capabilities on the drive in question, even when I map "name1" under the list of "root" next to admin and administrator, I cannot log on at all anymore using my "name1" password. I am a bit confused. All my smb.conf settings are right, I have each drive set as "writeable" and everything, but the samba software is not the issue. It is the fact that locally, only "root" has write permissions on the drive in question.


--------------------
Master:
Athlon XP 3200+ (400MHz FSB)
nForce2 400 Chipset
1GB Ultra PC3200 DDR-RAM
Onboard 7.1 Dolby Digital Sound
ATI Radeon 9800 Pro 128MB

Server:
Pentium III 1GHz 133MHz FSB
DFI Motherboard
1GB SD-RAM PC133
300GB Linux Drive w/ VFAT Partition
GeForce MX420 64MB

Laptop:
Apple G4 1.33GHz
512MB RAM PC2700
80GB HDD
Onboard Stereo Sound
ATI Radeon 9200 32MB
Go to the top of the page
 
+Quote Post
tendonut
post Dec 5 2004, 11:11 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 9
Joined: 3-May 04
Member No.: 2,880



Hey, I finally found out what the problem was, but this gave rise to another. The problem was I was trying to change the permissions of the mounted drive directory while the drive was still mounted. I didn't realize you couldn't do it that way. I was told to unmount the drive, create a new folder in a directory I normally had access to (a.k.a. HOME), change the permissions of that folder to FULL, then re-mount the drive. I did this all as root.

The problem I have now, is as soon as I remount the drive, the permissions I just changed of the mounting folder were reset to what they were before (Owner = Root, Group = Root, Group Permissions are R - X) so I am back to square 1. What am I doing wrong now?


--------------------
Master:
Athlon XP 3200+ (400MHz FSB)
nForce2 400 Chipset
1GB Ultra PC3200 DDR-RAM
Onboard 7.1 Dolby Digital Sound
ATI Radeon 9800 Pro 128MB

Server:
Pentium III 1GHz 133MHz FSB
DFI Motherboard
1GB SD-RAM PC133
300GB Linux Drive w/ VFAT Partition
GeForce MX420 64MB

Laptop:
Apple G4 1.33GHz
512MB RAM PC2700
80GB HDD
Onboard Stereo Sound
ATI Radeon 9200 32MB
Go to the top of the page
 
+Quote Post
michaelk
post Dec 6 2004, 06:59 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



You need to add the umask=000 option to the /etc/fstab entry.
Go to the top of the page
 
+Quote Post
tendonut
post Dec 6 2004, 01:31 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 9
Joined: 3-May 04
Member No.: 2,880



I just tried it, and it didn't work. I unmounted the drive, edited the fstab file, changed the permissions of the directory i am mounting to back to rwx, then remounted the drive and, once again, it became r-x. I DID notice that when I check the permissions of the directory, it says rwx, but as soon as I access the drive, then go back and check the directory again, it is back to r-x. Any other ideas?


--------------------
Master:
Athlon XP 3200+ (400MHz FSB)
nForce2 400 Chipset
1GB Ultra PC3200 DDR-RAM
Onboard 7.1 Dolby Digital Sound
ATI Radeon 9800 Pro 128MB

Server:
Pentium III 1GHz 133MHz FSB
DFI Motherboard
1GB SD-RAM PC133
300GB Linux Drive w/ VFAT Partition
GeForce MX420 64MB

Laptop:
Apple G4 1.33GHz
512MB RAM PC2700
80GB HDD
Onboard Stereo Sound
ATI Radeon 9200 32MB
Go to the top of the page
 
+Quote Post
twest
post Dec 29 2004, 12:11 AM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 29-December 04
Member No.: 4,403



I noticed that in my /etc/fstab file, I had to not only add "umask=000 0 0", but I also had to remove other entries like, "managed" and "noauto" so that I could automatically mount the partitions, then it worked fine. I struggled with this problem for 2 days ... Go Newbies
cool.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 05:58 PM