Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Unmounted Cd Problem., Unable to read from my CD.
jdoyleoss
post Dec 1 2004, 03:06 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 1-December 04
Member No.: 4,260



I performed my first ever Linux install of Suse 9.2 on an IBM A20, and immediately moved the hard drive over to a IBM 600X (older laptop).

One of the problems that I'm having is that it cannot read from the CD on this machine. When I login as a user, and view the CD in Konqueror it says that the CD is unmounted. When I try to enter it, I get an Error dialog that says "Could not enter folder /media/cdrom. All of this sounds fine. But when I run mount, it appears that the drive is mounted. I can't umount here, because I'm not root.

When I start a session as root, Konqueror and mount show the same behavior, but when I try to umount the drive, it succeeds, and I can then access it through Konqueror, but it doesn't show me any files. The folder appears empty. I then canít mount the drive again, mount complains that it " can't find dev/hdc in etc/fstab or /etc/mtab.

Any suggestions? Is there any way that I perhaps can do a general 'refresh' of all of the hardware, as there are probably other problems lurking from my hard drive switch? Please be specific, as I'm obviously a Linux newby.

Thanks
Go to the top of the page
 
+Quote Post
Peeyush Maurya
post Dec 4 2004, 05:27 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 4-December 04
Member No.: 4,280



command to check which devices is mounted.
mount
use this command to see if your cdrom is mounted ..if yes ..mounted to which directory..if its already mounted..umount it ..then insert cdrom and mount again

QUOTE
when I try to umount the drive, it succeeds, and I can then access it through Konqueror, but it doesn't show me any files. The folder appears empty. I then canít mount the drive again, mount complains that it " can't find dev/hdc in etc/fstab or /etc/mtab


once you had mounted the cdrom drive and if you see the drive content..it will definetly show it emtpy...this is normal. when mounting cdrom you have to specify complete command otherwise it look for the point point in /etc/fstab or /etc/mntab

mount /dev/hdc /mnt/cdrom
above it just an sample where ... /dev/hdc is cdrom drive..and .. /mnt/cdrom is the directory where you what to mount cdrom


Regards,
Peeyush Maurya
linux-faqs.com
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 01:51 PM