Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Help With Nic Drivers
JunLitsu
post Feb 4 2003, 03:14 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 4-February 03
Member No.: 408



I am trying to get my linux system (RH 8.0) connected to the internet. I downloaded the drivers: http://www.homepna.org/support/faqs.asp#FAQ6 and followed the following instructions


The following is the basic installation procedure. Different distributions may require different procedures, the information below should be considered guidelines. Most of the actions below require "root" privileges to be performed properly.

1. Make sure the PCI card is properly installed and found by the system. One way to check this is to execute
lspci
which will have several lines of output and one should be similar to:
01:0d.0 Ethernet controller: BROADCOM Corporation: Unknown device 4210
Alternatively, the Broadcom device may be found using:
cat /proc/pci
2. Make sure the kernel source code is installed. Sometimes this is called "development tools" during the install process. E.g. located in:
/usr/src/linux-X.Y.Z
3. Extract the driver files into a directory and cd to the directory. The driver EXE file can be extracted using MS Windows. Alternatively, the Wine utility may be used to extract under linux. Using Wine has some quirks such as: extracting to the default directory does not work, use a /tmp directory instead and clicking on some buttons doesn't work, use the Return key instead.
4. Determine the kernel version. One way of determining the kernal version is to execute
uname -a
or to check the subdirectories in
/lib/modules
Some example kernel versions:
RedHat 5.0 too old for the driver
RedHat 7.0 2.2.16
RedHat 7.1 2.4.2
RedHat 7.2 2.4.7-10
RedHat 7.3 2.4.18-3
Mandrake 8.1 2.4.8
Mandrake 8.2 compiler not installed corectly in distribution
5. Execute gmake with the correct kernel version for your distribution e.g:
gmake LINUXVER=2.2.16 (for RedHat 7.0)
gmake LINUXVER=2.4.2 (for RedHat 7.1)
gmake LINUXVER=2.4.7-10 (for RedHat 7.2)
gmake LINUXVER=2.4.18-3 (for RedHat 7.3)
gmake LINUXVER=2.4.8 (for Mandrake 8.1)
This command depends on the kernel sources being in /usr/src/linux-X.Y.Z
6. If the compilation is successful, the file "il.o" will be created. Copy il.o to the "net" modules directory. e.g.:
cp il.o /lib/modules/2.2.16-22/net/ (for RedHat 7.0)
cp il.o /lib/modules/2.4.2/kernel/net/ (for RedHat 7.1)
cp il.o /lib/modules/2.4.7-10/kernel/net/ (for RedHat 7.2)
cp il.o /lib/modules/2.4.18-3/kernel/net/ (for RedHat 7.3)
cp il.o /lib/modules/2.4.8-26mdk/kernel/net (for Mandrake 8.1)
Make sure the owner of il.o is root
7. Temporarily install the module by executing:
insmod il

After it loads, syslog will record something like:
eth0: Broadcom InsideLinex0 PCI Network Adapter 2.34.0.2
If in console mode, the syslog line will be immediately displayed. If in a windows/graphical mode, you will need to grep the syslog:
grep Broadcom /var/log/*
to see the load output.
8. Edit file /etc/modules.conf to add an alias for this new module. (some of the older versions name this file /etc/modules.conf) The second word in the alias should be the same number as shown in the previous step. In most cases, when this is the first and only network interface it is "eth0". If there are other EtherNet adapets it could be "eth1" or "eth2". So the typical line that is added to the file is:
alias eth0 il

9. Create an interface config file in

/etc/sysconfig/network-scripts
Assuming the interface number is "eth0" the file name should be "ifcfg-eth0". This file can be created in one of several ways depending on how you want to setup your network. For example, to use static addresses, you can copy the content of ifcfg-lo to ifcfg-eth0 and edit the contents of ifcfg-eth0 to look something like:
DEVICE=eth0
IPADDR=192.168.0.33
NETMASK=255.255.255.0
BROADCAST=255.255.255.255
ONBOOT=yes
Dynamic (DHCP) networks should have a file ifcfg-eth0 with contents similar to:
DEVICE=eth0
BOOTPROT=dhcp
ONBOOT=yes
10. Bring the interface up: ifup eth0 If there are other HomePNA adapters connected to the Linux adapter, the "link" light should turn on. The interfaces can also be checked with the command:
ifconfig
11. With the above configration, the HomePNA module should load and the interface brought up automatically after a reboot.

At step 5 it woudln't work until I changed the source code from malloc.h to slab.h because the compiler said so.
Then at step 7 it told me that the module was compiled using gcc version 2 and that my kernel was compiled using version 3 and that it was known not to work.

Is there someway I could force either the module to be compiled in gcc 2 or do something with my kernel?
I have no problems with the otehr steps, thanks in advance for responding.

I am using (attempting to anyways) the linksys hpn200 home phoneline network card
Go to the top of the page
 
+Quote Post
Corey
post Feb 6 2003, 09:07 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



Well, you basically have 2 choices here, you could A) Recompile your kernel with the compiler you currently have installed (which i'm guessing is gcc 2.95) or you can upgrade your compiler to gcc 3 by downloading it from their website. You're system will break in half if you try to insert module code compiled with gcc2 intoa gcc3 running kernel. I believe redhat comes with gcc3 as well if you choose to install it. Run the install program thingy in Redhat and make sure everything in "kernel development" is checked off. (Sorry, not much experience with redhat).


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
JunLitsu
post Feb 7 2003, 01:58 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 4-February 03
Member No.: 408



thanks for the advice but I know that I am running gcc 3.97 (or 79 not sure)
when I run make -v it says gcc 3.97 blablablabla
does it have somethign to do with the makefile in the driver folder?
edit: my mistake, I am it says I am running make 3.79 and that I am running gcc 3.2. But that still doesn't change anything. Are the driver files version specific or somethign and are they forcing the compiler to use an older version?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 12:28 AM