Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Partition Issues, boot loading
smb2004
post Oct 21 2004, 11:24 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 10
Joined: 11-June 04
Member No.: 3,142



hey,
ok, i have my xp partion on hda5, and a longhorn installed on hdb1. i read up on ubuntu on distrowatch, and after being without linux for a few week, though i would give it a try, after an error during install, i was left being unable to boot into anything. so i installed suse, which i am currently running. now, grub, when i try and load into my xp, it gives an error, and longhorn is not even an option. how can i go about either setting suse to access both of those, or prefferably just repairing the bootloader to get both of those back, or install another distro to fix them. any suggestions......thanks

(also my keyboard is set for german, expect yast says its for english)
Go to the top of the page
 
+Quote Post
Jim
post Oct 21 2004, 01:42 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



You need to add entries to your /boot/grub/grub.conf file.

Your windows entries should look something like this...
CODE
title= Windows
root (hd0,0)
makeactive
chainloader +1


If you don't know how grub references drives, it starts at 0 instread of 1, so hda5 would be (hd0,4).

That should work for you.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
smb2004
post Oct 21 2004, 05:22 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 10
Joined: 11-June 04
Member No.: 3,142



i changed the windows setting to (hd0, 4)
now when i try it give the error:

root (hd0, 4)
filesystem type unknown, partition type 0x7
chainloader +1


is there a way to bypass grub and get to the windows bootloader, or reset the windows bootloader to over write grub. i probally didn't pick the best time to do this, because i need acess to some of my windows programs. i only need to get into xp, which is on hda5.
Go to the top of the page
 
+Quote Post
michaelk
post Oct 21 2004, 08:29 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



Should be:
rootnoverify (hd0,4)

To restore XP bootloader you will need to boot using the XP install CD and select recovery mode. Then run the fixmbr utility.
Go to the top of the page
 
+Quote Post
smb2004
post Oct 22 2004, 11:45 AM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 10
Joined: 11-June 04
Member No.: 3,142



i changed the grub setting to rootnoverify, but when i tried to load windows i got the screen :

rootnoverift
chainload +1

and a blinking curser, thats it.

then i loaded into winodws xp recovery and ran fixmrb, now when i try and boot i get:

error loading opereating system

hmmm.....what should i do now? there is also a bootcfg within the recovery console, but im not sure how to use that....what should the os options be? also i cant access grub anymore, so i cant boot into anything.....thank goodness for knoppix! thanks for the help do far, but more is appreated!
~matt
Go to the top of the page
 
+Quote Post
michaelk
post Oct 22 2004, 12:38 PM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



This might help:
http://portal.suse.com/sdb/en/2004/05/fhas..._booting91.html
Go to the top of the page
 
+Quote Post
smb2004
post Oct 23 2004, 06:10 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 10
Joined: 11-June 04
Member No.: 3,142



unfortionaly, that was unable to do any good, i had already reset the mbr, so i none of that work. i ended up reformating my linux partition to a fat32 using knoppix, then through phlak i trashered the files i needed from my ntfs xp partition to my fat32 on (knoppix woulnt let me for some reason...read only on fat32....phlak let me write), then reinstalled windows, and am trasnfering my files back to ntfs partition. i think i shold really run md5sum next time i go to install linux wink.gif......all is well now, althoug i did lose my longhorn, but thats no big deal.
Go to the top of the page
 
+Quote Post
Jim
post Oct 23 2004, 11:37 PM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



Knoppix will let you read and write to fat32, you just have to mount it manually. If you just mount it by clicking on the icon on the desktop it mounts it read only. So next time, you can go ahead and use knoppix if you want. Just mount it from the command line manually.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
smb2004
post Oct 24 2004, 01:42 PM
Post #9


Whats this Lie-nix Thing?
*

Group: Members
Posts: 10
Joined: 11-June 04
Member No.: 3,142



ahhhhh gotcha. i'll keep that in mind...thanks!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th October 2017 - 05:25 PM