Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Perl Clamav Module, can't compile mail-ClamAV
eradrix
post Oct 13 2004, 05:50 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 13-October 04
From: Switzerland (french side)
Member No.: 3,949



Hi

I wanted to follow your guide "Installing A Postfix Mail Server {On RHEL or Clones (Like WBEL / CentOS / TaoLinux)}" for my WBEL server
All was fine until I tried to install Mail::ClamAV using CPAN

Here's what I get on screen:
CODE
cpan> install Mail::ClamAV
Running install for module Mail::ClamAV
Running make for S/SA/SABECK/Mail-ClamAV-0.11.tar.gz
Fetching with LWP:
 ftp://cpan.cict.fr/pub/CPAN/authors/id/S/SA/SABECK/Mail-ClamAV-0.11.tar.gz
Fetching with LWP:
 ftp://cpan.cict.fr/pub/CPAN/authors/id/S/SA/SABECK/CHECKSUMS
Checksum for /root/.cpan/sources/authors/id/S/SA/SABECK/Mail-ClamAV-0.11.tar.gz ok
Mail-ClamAV-0.11/
Mail-ClamAV-0.11/t/
Mail-ClamAV-0.11/t/virus.eml
Mail-ClamAV-0.11/t/Mail-ClamAV.t
Mail-ClamAV-0.11/README
Mail-ClamAV-0.11/ClamAV.pm
Mail-ClamAV-0.11/config.pl
Mail-ClamAV-0.11/Changes
Mail-ClamAV-0.11/Makefile.PL
Mail-ClamAV-0.11/META.yml
Mail-ClamAV-0.11/INSTALL
Mail-ClamAV-0.11/MANIFEST

 CPAN.pm: Going to build S/SA/SABECK/Mail-ClamAV-0.11.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for Mail::ClamAV
cp ClamAV.pm blib/lib/Mail/ClamAV.pm
/usr/bin/perl -Mblib -MInline=NOISY,_INSTALL_ -MMail::ClamAV -e1 0.11 blib/arch
Starting Build Prepocess Stage
Finished Build Prepocess Stage

Starting Build Parse Stage
Finished Build Parse Stage

Starting Build Glue 1 Stage
Finished Build Glue 1 Stage

Starting Build Glue 2 Stage
Finished Build Glue 2 Stage

Starting Build Glue 3 Stage
Finished Build Glue 3 Stage

Starting Build Compile Stage
 Starting "perl Makefile.PL" Stage
Writing Makefile for Mail::ClamAV
 Finished "perl Makefile.PL" Stage

 Starting "make" Stage
make[1]: Entre dans le répertoire `/root/.cpan/build/Mail-ClamAV-0.11/_Inline/build/Mail/ClamAV'
/usr/bin/perl /usr/lib/perl5/5.8.0/ExtUtils/xsubpp  -typemap /usr/lib/perl5/5.8.0/ExtUtils/typemap   ClamAV.xs > ClamAV.xsc && mv ClamAV.xsc ClamAV.c
gcc -c  -I/root/.cpan/build/Mail-ClamAV-0.11 -I/usr/include -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -g -pipe -march=i386 -mcpu=i686   -DVERSION="0.11" -DXS_VERSION="0.11" -fPIC "-I/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE"   ClamAV.c
ClamAV.xs: Dans la fonction « clamav_perl_constant »:
ClamAV.xs:282: « CL_SCAN_ENCRYPTED » non déclaré (première utilisation dans cette fonction)
ClamAV.xs:282: (Chaque identificateur non déclaré est rapporté une seule fois
ClamAV.xs:282: pour chaque fonction dans laquelle il apparaît.)
ClamAV.xs:284: « CL_NUM_CHILDS » non déclaré (première utilisation dans cette fonction)
ClamAV.xs:285: « CL_MIN_LENGTH » non déclaré (première utilisation dans cette fonction)
make[1]: *** [ClamAV.o] Erreur 1
make[1]: Quitte le répertoire `/root/.cpan/build/Mail-ClamAV-0.11/_Inline/build/Mail/ClamAV'

A problem was encountered while attempting to compile and install your Inline
C code. The command that failed was:
 make

The build directory was:
/root/.cpan/build/Mail-ClamAV-0.11/_Inline/build/Mail/ClamAV

To debug the problem, cd to the build directory, and inspect the output files.

at /root/.cpan/build/Mail-ClamAV-0.11/blib/lib/Mail/ClamAV.pm line 159
BEGIN failed--compilation aborted at /root/.cpan/build/Mail-ClamAV-0.11/blib/lib/Mail/ClamAV.pm line 447.
Compilation failed in require.
BEGIN failed--compilation aborted.
make: *** [ClamAV.inl] Erreur 2
 /usr/bin/make  -- NOT OK
Running make test
 Can't test without successful make
Running make install
 make had returned bad status, install seems impossible


Of course, this is the same problem if I try to install by myself using the sources
sad.gif

I'd appreciate any help... unsure.gif
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 13 2004, 08:13 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Try doing the following before entering CPAN:

export LANG=C

then try again...


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
eradrix
post Oct 14 2004, 03:28 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 13-October 04
From: Switzerland (french side)
Member No.: 3,949



looks like the same... sad.gif

Just one thing about guide's part.4 : the link you give (wget http://crash.fce.vutbr.cz/crash-hat/2/clam...0.74-1.src.rpm) is out of date.
In clamav folder there is now clamav-0.80rc4-1.src.rpm so I used this release. I hope there is no consequence... unsure.gif


So, for the moment I use clamav instead clamavmodule in MailScanner.conf (by the way, you didn't explain in your guide why you prefer clamavmodule. Can you tell me more about that?)


Would you also advise me about my sql log?
CODE
041014 17:12:55  mysqld started
Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
If you do not want to use transactional InnoDB tables, add a line
skip-innodb
to the [mysqld] section of init parameters in your my.cnf
or my.ini. If you want to use InnoDB tables, add to the [mysqld]
section, for example,
innodb_data_file_path = ibdata1:10M:autoextend
But to get good performance you should adjust for your hardware
the InnoDB startup options listed in section 2 at
http://www.innodb.com/ibman.html
/usr/libexec/mysqld: ready for connections

According to you, what is the best action? To enter a path or to enter skip-innodb? unsure.gif
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 14 2004, 08:20 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Not a real large difference between the two (calmav and clamavmodule) ... I used clamavmodule because it uses slightly less resources for very high volume mail servers.

I haven't tried the install with the latest source rpms ... but I will try it soon and update the guide.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
eradrix
post Oct 15 2004, 01:28 AM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 13-October 04
From: Switzerland (french side)
Member No.: 3,949



Thanks smile.gif And what about the mysql setup?
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 15 2004, 06:38 PM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Still checking the mysql ... but the clamav module is a bug ... see this link:

http://lists.clamav.net/lurker/message/200...232c672.en.html

I installed 0.74 (from my website), installed the module via CPAN, removed 0.74 and installed 0.80rc4. I then installed MailScanner-4.35.4-1.rpm.tar.gz.

Everything else went as planned.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
eradrix
post Oct 15 2004, 07:08 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 13-October 04
From: Switzerland (french side)
Member No.: 3,949



I'll try asap (I'll be away for one week). Thanks again smile.gif
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 15 2004, 07:36 PM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



As to the MySQL issue, there is more than one table type for MySQL. One of the table types is:

InnoDB

That is actually the best way (in my opinion) to do MySQL tables, but I haven't enabled it in MySQL 3.23 installs (like the one for WBEL/CentOS). It is installed by default in MySQL 4.

In this case, I would put:

skip-innodb

as the last line in the [mysqld] section of /etc/my.cnf

--------------
Note: You can leave it alone ... and you will get the error in the logs, but InnoDB will not start...


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
eradrix
post Nov 21 2004, 07:48 PM
Post #9


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 13-October 04
From: Switzerland (french side)
Member No.: 3,949



QUOTE (hughesjr @ Oct 16 2004, 01:38 AM)
Still checking the mysql ... but the clamav module is a bug ... see this link:

http://lists.clamav.net/lurker/message/200...232c672.en.html

I installed 0.74 (from my website), installed the module via CPAN, removed 0.74 and installed 0.80rc4. I then installed MailScanner-4.35.4-1.rpm.tar.gz.

Everything else went as planned.

laugh.gif


I did that this evening (yes, there was a long time). rpm -e clamav clamav-devel, rpm -e mailscanner, and followed your instructions. I got new errors! I thought I was becoming crazy!

... until I realized that the clamav module had been updated biggrin.gif

So I did rpm-e clamav clamav-devel again, installed the recent one, and all ran perfectly wink.gif
Go to the top of the page
 
+Quote Post
eradrix
post Nov 21 2004, 08:26 PM
Post #10


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 13-October 04
From: Switzerland (french side)
Member No.: 3,949



May I ask you more?

This is perfect for my own server's user account and for my own domain. Then what would be the next action to perform in order to setup email-only for the people which I don't want to create a "real" account, (for my own domain, and for virtual domains too)? Do I need something like LDAP?(I don't know exactly what it is)... unsure.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th October 2017 - 02:34 AM