Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Firefox Install And Now Kpackage Woes
gorby
post Oct 13 2004, 10:18 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 13-October 04
Member No.: 3,945



Hi there,
Ive been useing Debian for around a week now (linux for around 2) and having really good fun with it. I decided id like to install firefox so downloaded the graphical installer (firefox-1.0PR-i686-linux-gtk2+xft-installer.tar)

After unpacking i sent it to /usr/bin and ran ./firefox-installer.
That told me that i needed libstdc++.so.5. I learnt that this package is not stable yet (i couldnt get it through apt-get) so i Dl'ed it from debains site.
there were lots of dependencies for this package so i got them too.
(gcc-3.3-base_3.3.4-13, libc6_2.3.2) There was also a dependency for libc6 (libdb1-comp) So i tried installing these through package manager and got depndancy errors on pretty much every one.
Now i think ive messed up something pretty serious because when i try to launch kpackage I get an error when loading ibdb.so.2 (presumably because the failed above install)
So, lots of problems but not sure what to do. Ive tried doing apt-get build-dep kpackage and removing and re-installing various things but cant seem to get it back up and running.
After ive fixed that id like to get firefox up again, is there a way of installing the packages at the same time to get around the dependency issues?

Cheers for helping with my mess tongue.gif
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 13 2004, 06:48 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



If you want to use firefox, install debain sarge instead of debain woody.

For now, the easiest way to get from Woody to Sarge is to edit the file /etc/apt/sources.list and change each line that is not a security update from stable to test ... my sources.list looks like this:
CODE
deb http://mirrors.kernel.org/debian/ testing main
deb-src http://mirrors.kernel.org/debian/ testing main

deb http://security.debian.org/ stable/updates main


After you change sources.list, run the command:

dselect update

then do:

dselect select

(press enter to go in ... you should be able to press enter again to bring up any upgrade issues that are going to need to be solved ... then just press enter again for auto resolving of all issues ... then press enter again to exit).

Then do the command:

dselect install

This will install all upgrades...

Afterwards, remove the manually installed firefox and issue the command:

apt-get update

then

apt-get install mozilla-firefox

(the version is actually 0.9.3 right now in Debian Sarge and Debian SID ... but it should move to 1.0PR soon)




---------------------------
If you can do a new install ... just download the


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
gorby
post Oct 14 2004, 10:22 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 13-October 04
Member No.: 3,945



thanks for all your help. I followed your instructions and rebooted and now its running gnome i was able to install and run firefox with no problems.
Currently reverting back to kde.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 14th December 2017 - 09:59 AM