Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Need Help Mounting Xp Partition
dbooster
post Feb 2 2003, 10:45 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 2-February 03
Member No.: 397



I just reinstalled suse 8.1, but for some reason it didn't autoconfig my xp partition to mount like it normally does. Easy enough to fix I figure...

I added this to my fstab:
/dev/hda1 /mnt/nt ntfs user 0 0

ok. It automounts fine, but only root has access. I thought the "user" up there would give all users access, but nope, I can't get in unless I su to root. I read on one forum that it would work if I added noauto after user, but nope. After I mount it as teh user it is still readable only by root. I suppose I could su to root everytime I needed something on xp, but this would be awfully inconvient. Please help!!

-dave
Go to the top of the page
 
+Quote Post
dbooster
post Feb 3 2003, 10:04 AM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 2-February 03
Member No.: 397



anyone??
Go to the top of the page
 
+Quote Post
chrisw
post Feb 3 2003, 11:18 AM
Post #3


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



it is not advisable to write to a NTFS partition from linux
you should just read from it for now..i think you have
to compile in kernel support to write to a NTFS partition
anyway, to keep people from writing to such partition.


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
dbooster
post Feb 3 2003, 11:46 AM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 2-February 03
Member No.: 397



I don't want to write to it - just read it. I assume it is possible to allow a regular user to read the ntfs drive because suse usually automatically sets it up to allow me to do this. I just can't figure out how to set this up myself and that's my question. I can get the root to read it, but not the regular user.
Go to the top of the page
 
+Quote Post
wwpusa
post Feb 3 2003, 08:02 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 3-February 03
From: Georgia
Member No.: 406



Can't u just set permissions for usr? wink.gif


--------------------
wwpusa Computer Junkie Extrodinair
Go to the top of the page
 
+Quote Post
dragons_fyre
post Feb 4 2003, 01:59 AM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 3-February 03
Member No.: 405



Perhaps I'm missing the topic of this post, but if Not here I go.

As far as the partitioins go I just created one large primary partition. From there I setup an extended partition. Then I created three logical drives on the extended partition. The first logical drive I set for 6 gigs which is where the main part of linux is set with the file system hex designation as 83 I believe. Then the second logical drive was for my swap and that was 600 megs and set that as 82 I think. I may have those mixed up. Then my third logical drive is a 3 gig shared drive which I use to share files between linux and windows. I used a FAT32 file system for that. I haven't had any problems with users and what not having it setup like this. Like I said I don't know if I am off subject or not. But hoped it helped
Go to the top of the page
 
+Quote Post
dbooster
post Feb 4 2003, 12:11 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 2-February 03
Member No.: 397



Hmm... I guess I'm not being clear.

I have 2 partitions: ntfs and linux. When I normally install suse, it creates a folder on my desktop (in kde or gnome) that gives me read-only access to my ntfs drive. It otherwords, it automounts the drive for me, and gives access to both user and root.

When I reinstalled suse this time, it didn't provide this folder for me. I suppose I missed the option in the install. Anyways, so I am trying to provide the same thing on my own. But it isn't quite working.

When I mount the ntfs drive, the premissions are automatically set to read-only for root and nothing for the user. That is, root has ro access, but user can't even view the drive. I can't figure out how to change this. I can't chmod the dir - it just won't let me. I tryed setting the user option in the fstab, but that didn't work either. I have no idea what else to try!

wwpusa: If chmoding the folder isn't what you meant for setting permissions of user, than what did you? Keep in mind, I'm still very much a linux newbie (dispite being a CS grad)
Go to the top of the page
 
+Quote Post
Corey
post Feb 6 2003, 09:03 AM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



Check out the manpage for mount and look for the mount options for an ntfs filesystem. Check the options for "uid" and "gid".


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 07:42 PM