Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Installed Fedora Glibc Upgrade On Rh 7.3, Help!
apc21
post Sep 28 2004, 02:38 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 28-September 04
Member No.: 3,854



Yeah, I know, I did something very stupid! I was making some upgrades on my Red Hat 7.3 server carelessly and now I'm $90 in tech support debt ($45 per half hour) and still no solution. I run about 7 websites and my Apache web server (self-managed) won't start...

Here is what my Apache error log says:
QUOTE
/usr/sbin/httpd: relocation error: /lib/libpthread.so.0: symbol __libc_fork, version GLIBC_2.1.2 not defined in file libc.so.6 with link time reference


Right now I can't even use the tar command (get a similar error to the one above) so I have to rely on RPM packages for fixes.

Here is the history of my tech support replies:
QUOTE
We have reinstalled glibc and your system is now booting and accessible via ssh. However, there are still some applications that appear to have issues, including Apache and Bind. It is possible that they will have to be reinstalled as well, but we felt at this point now that you can log in that we should give you the option of fixing these yourself. You have currently incurred one hour of admin time, chargeable at $45 per half hour under the self-managed plan. Please let us know how you would like us to proceed.
-----------------------------
We have reinstalled the base glibc installation from Redhat 7.3, but it appears that you are still having errors when loading Apache and BIND.

The RPM's we installed are:
glibc-2.2.5-34-i386.rpm
glibc-common-2.2.5-34.i386.rpm
glibc-devel-2.2.5-34.i386.rpm
glibc-kernheaders-2.4-7.14.i386.rpm

These are packages from your original installation. I need to know if you have installed any additional packages that we might not be aware of. From what I can see, all of your package versions look to be correct. Please update this ticket and let us know if we are missing something.
-----------------------------
The Glibc for Fedora RPM's were installed on the server Ver Red Hat 7.3. Which broke many dependencies on your server. This is a bilable issue this will take aprox about 1 hour to fix.
Please call our tech support department if you have any questions.


If anyone has any ideas on a possible solution, please let me know, as I've been spending hours on this problem and still coming to no solution. Any help would be very appreciated!
Go to the top of the page
 
+Quote Post
hughesjr
post Sep 29 2004, 05:58 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Are the apache and bind versions installed on the server built from source or installed via RPM?

I assume you don't have a full backup smile.gif

At this point, I would probably just put a new hard drive in the system in addition to the current drive (or create a new partition if you have room), and install a new Linux OS with Apache, PHP, MySQL and bind and anything else you need ... then copy over all the config files and data from your sites to the new drive.
----------------------------------
OR - If all your packages have been installed via RPM, you can do:

rpm -qa

and compare that to this for the last redhat updates:
Redhat 7.3 Install
Redhat 7.3 updates

Or compare the rpm -qa to this (which I recommend):
FedoraLegacy for RH7.3 base
FedoraLegacy for RH7.3 updates

Install any packages that don't matchup ... force if necessary.

(ie ... rpm -ivh --force package1 package2 package3)
------------------------
The best bet though, in my opinion, is to reinstall on a seperate drive and copy the config files and any other data over. If you are reinstalling, I would recommend a RedHat Enterprise 3 clone like CentOS or WhiteBox Enterprise Linux


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
apc21
post Sep 29 2004, 06:49 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 28-September 04
Member No.: 3,854



Thanks for the reply (=

I ended up installing YUM and doing an update, and now everything seems to be fixed! Yum rocks...
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th December 2017 - 08:59 AM