Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Cdrom Not A Valid Block Device, Accessing cdrom
jh_admin
post Sep 21 2004, 10:16 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 21-September 04
Member No.: 3,808



Hi,

I have a server running redhat 9 - kernel 2.4

I am trying to mount the cd drive and am getting the following reponse to the command mount /mnt/cdrom

mount: /dev/cdrom is not a valid block device

Looking at dmesg shows the cd rom was detected at boot time.

cat dmesg | grep -i cd
hdc: MATSHITA CR-177, ATAPI CD/DVD-ROM drive

From /etc/fstab

/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0

Doing ls –l /dev/cdrom I can see /dev/cdrom is pointing at hdd

lrwxrwxrwx 1 root root 3 Feb 10 2004 /dev/cdrom -> hdd

In this, what is hdd? Is it related to ‘hdc’ from dmesg?
Should /dev/cdrom be pointed at /dev/hdd instead?

I have tried finding a solution on the web without success, hence this post.

Thanking you in advance,

jols
Go to the top of the page
 
+Quote Post
michaelk
post Sep 21 2004, 03:57 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



Have you changed the hardware configuration lately? Do have have anything installed on the second IDE controller slave position?
/dev/hda - 1st IDE controller master
/dev/hdb - 1st IDE controller slave
/dev/hdc - 2nd IDE controller master
/dev/hdd - 2nd IDE controller slave
and so on.....

Your correct /dev/cdrom is linked to the wrong device. It should be hdc and not hdd.
To change /dev/cdrom from hdd to hdc, log in as root (via su)
rm /dev/cdrom ( deletes existing link)
ln -s /dev/hdc /dev/cdrom (create new link)
Go to the top of the page
 
+Quote Post
tall_chris_11
post Oct 6 2004, 09:22 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 6-October 04
Member No.: 3,905



If you run an older kernel with legacy scsi cdrom you will need an option like:
append="hdc=ide-scsi"
in your /etc/lilo.conf file. If you run a newer kernel, like 2.6.x, and didn't compile in this option, make sure you remove that line(or at least the hdc=ide-scsi part of it).
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 02:23 PM