Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Password Expiriation Problems, Problem with password expiring
sjolly11
post Sep 20 2004, 01:41 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 20-September 04
Member No.: 3,802



Hi,
I am currently having a problem on my Red Hat ES 2.1 Install with passwords. Users cannot change their passwords when it expires. Before the problem, when someone logged in, it would state how many days they had till their password expires. When it expired they could change it to something new. Now it doesn't say how long they have till it expires and when it expires it doesn't even give them a chance to change it, the session will just close. So if they need their password changed, they need to come to me to change it for them. Currently they are not permitted to have access to the Command Line by the way. If you need any further information, please let me know.
Thanks.
Stephen
Go to the top of the page
 
+Quote Post
michaelk
post Sep 20 2004, 05:27 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



Have you checked the status of the users passwd to see how they are configured?
passwd -S <username>

BTW those parameters all configurable using the passwd command.
Go to the top of the page
 
+Quote Post
sjolly11
post Sep 27 2004, 11:04 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 20-September 04
Member No.: 3,802



I got it figured out.
The accounts in the shadow file had their Inactivity Field Set to 0. With it being 0, it does not disable inactivate the account, it inactivates the account the same day the password expires. I changed it to a -1 and lo and behold, the user could change their password when they logged in.
I am going to go through now and set everyone to a -1 so that it will finally fix this problem and set everyone straight.
Stephen
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 10:30 AM