Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Moutning A Usb Thumb Drive As Read/write
GiZiM
post Sep 15 2004, 09:59 PM
Post #1


Grub-er
**

Group: Members
Posts: 31
Joined: 24-August 04
Member No.: 3,619



Yeah like it says i have it mounted but i cant Write to it i have it setup in fstab as this
/dev/sda1 /mnt/cardreader vfat rw,noauto,users 0 0

Any ideas?


--------------------
~ GiZiM ~
GiZiM.Net

Red Hat Fedore Core 2
N00B
Go to the top of the page
 
+Quote Post
michaelk
post Sep 15 2004, 10:40 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



Add the option umask=000 to the fstab entry for read / write.
Go to the top of the page
 
+Quote Post
GiZiM
post Sep 17 2004, 05:10 PM
Post #3


Grub-er
**

Group: Members
Posts: 31
Joined: 24-August 04
Member No.: 3,619



Nope didnt fix it


--------------------
~ GiZiM ~
GiZiM.Net

Red Hat Fedore Core 2
N00B
Go to the top of the page
 
+Quote Post
michaelk
post Sep 17 2004, 10:17 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



With the drive unmounted make sure the permissions for /mnt/cardreader are set for read/write.
Then remount the drive.

BTW is this as a regular user or as root?
Go to the top of the page
 
+Quote Post
GiZiM
post Sep 21 2004, 09:40 PM
Post #5


Grub-er
**

Group: Members
Posts: 31
Joined: 24-August 04
Member No.: 3,619



QUOTE (michaelk @ Sep 17 2004, 09:17 PM)
With the drive unmounted make sure the permissions for /mnt/cardreader are set for read/write.
Then remount the drive.

BTW is this as a regular user or as root?

Ok lets try this all over again

/dev/sda1 /mnt/cardreader vfat rw,noauto,umask=000,users 0 0

that is what it looks like in my fstab

When i try to mount what is in my fstab i get this

[root@localhost /]# mount -a
mount: mount point 0 does not exist
[root@localhost /]#


i am trying to mount in a user profile


--------------------
~ GiZiM ~
GiZiM.Net

Red Hat Fedore Core 2
N00B
Go to the top of the page
 
+Quote Post
michaelk
post Sep 22 2004, 05:58 AM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



QUOTE
mount: mount point 0 does not exist

It is difficult to tell if this error is related to the card reader or some other error in the fstab file.
Does the directory /mnt/cardreader exist?

What happens when you try to mount the card reader?
mount /mnt/cardreader

Might want to post the rest of the fstab file.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2017 - 11:04 AM