Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Cd Mounting Probs, Mandrake 10 / KDE 3 cd mounting issues
deanonet
post Sep 15 2004, 04:34 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 15-September 04
Member No.: 3,774



I am running Mandrake 10 with KDE 3 and am having trouble with CD mounting.
After ZI have booted the machine (laptop) and place in a CD, I get the CD icon on the desktop and can access it as I should. Once I run a program from it or copy files from the CD to the HDD, the 'mounted' icon dissapears from the desktop. I cannot umount it as it contantly says the device is busy and when I change over CD's manually, I get a directory listing of directories and files with question marks. In order to re-mount a cd in the drive, I have to reboot the machine (probably not neccessary but not know another way).
I have never seen this proble before with any other version of Linux. The one program that I am using but always shut down before a umount is Wine.

Any ideas??????

Dean
Go to the top of the page
 
+Quote Post
michaelk
post Sep 15 2004, 06:28 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,796
Joined: 23-January 03
Member No.: 360



Since Mandrake uses supermount by default I assume it is still enabled which means you do not need to explicitily use the unmount command. Since supermount is using the drive it might appear busy to the unmount command however, you should still be able to eject the disk.
Go to the top of the page
 
+Quote Post
deanonet
post Sep 15 2004, 08:47 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 15-September 04
Member No.: 3,774



I can physically eject the disc and if I insert the same cd, all is fine. However, if I replace it with another cd, all I get is the question marks as the file & folder descriptors. The system keeps reporting that 'device is busy' and will not allow it to be unmounted.
I cannot find any trace of the problem in any of the logs sad.gif
Go to the top of the page
 
+Quote Post
michaelk
post Sep 15 2004, 10:39 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,796
Joined: 23-January 03
Member No.: 360



If running supermount then disable it.
Go to the top of the page
 
+Quote Post
deanonet
post Sep 15 2004, 05:48 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 15-September 04
Member No.: 3,774



I have had a look through the system config options but could not find anyhting with supermount. Do you have an idea to do this?

Dean
Go to the top of the page
 
+Quote Post
deanonet
post Sep 15 2004, 06:04 PM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 15-September 04
Member No.: 3,774



I managed to fix it by removing the 'auto' from the cd line in /etc/fstab. I left the original line in there but commented it out just in case something went wrong. All works now with manual mounting and umounting of the cd drive.

[CODE]
/dev/hda3 / ext3 noatime,defaults 1 1
none /dev/pts devpts mode=0620 0 0
#/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
/dev/hdc /mnt/cdrom umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/windows ntfs umask=0,nls=iso8859-1,ro,gid=users,users 0 0
none /proc proc defaults 0 0
/dev/hda2 swap swap pri=42 0 0
none /mnt/removable supermount dev=/dev/scsi/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0

Thanks for your help and point in the right direction biggrin.gif

Dean
Go to the top of the page
 
+Quote Post
deanonet
post Sep 15 2004, 06:43 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 15-September 04
Member No.: 3,774



Okay,
back again. still not working. Just played a dvd through Xine, stoppped it and still got the same error message.

CODE
[root@thelaptop root]# umount /mnt/cdrom
umount: /mnt/cdrom: device is busy
umount: /mnt/cdrom: device is busy


typing eject won't work either...

CODE
eject: unmount of `/dev/ide/host0/bus1/target0/lun0/cd' failed


I can' t think that another application would be locking it as I have tried closing every program and moving back down directories so that nothing is accessing the cd rom drive.


Frustrated blink.gif
Go to the top of the page
 
+Quote Post
michaelk
post Sep 15 2004, 08:39 PM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,796
Joined: 23-January 03
Member No.: 360



Movies and music discs can not be mounted nor unmounted because they do not contain a vaild filesystem.

I'm supprised it worked at all without the auto. This tells the OS what type of filesystem it is supposed to mount.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th October 2017 - 05:18 PM