Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> How To Recreate Grub, or boot from floppy
Robert83
post Sep 4 2004, 09:04 AM
Post #1


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

I had WinXP Pro (FAT32) and Suse 9.1PRO (ext3), my WinXP was pretty screwed up and when I got my hands on doom3 I needed to reinstall it fast smile.gif , so now it's :

IDE 1 [MASTER] Disk1 (WinXP NTFS)
[SLAVE] Disk2 (NTFS, ext3 /boot)

IDE 2 [MASTER] DVD Writer
[SLAVE] Disk3 (ext3 / /disk2 swap)

I've tried Hughesjr's solution

rebooted with the Suse 9.1 DVD recovery option , entered as root did the following :
mkdir /mnt/fixgrub
mount /dev/hdd1 /mnt/fixgrub (/dev/hdd1 - is my root)
mount /dev/hdb8 /mnt/fixgrub/boot (/dev/hdb8 - is my boot)

chroot /mnt/fixgrub
grub
root (hd0)

and got this error :

filesystem type unknown, using whole disk this maybe because my primary drive is now NTFS ? is there a way around this ? /dev/hdb8 was made because I must be able to remove that 20GB removable drive when I get some new movies or mp3's so I think I cannot rebuild grub on disk3 , cause my system would not be able to boot up if I removed it right?


anyway the next thing I've tried is create a grub boot disk :

mkdir /mnt/fixgrub
mount /dev/hdd1 /mnt/fixgrub
mount /dev/hdb8 /mnt/fixgrub/boot

it told me to look for a stage1 and stage2 in /usr/share/grub/i386-pc/ but I found it only in /boot/grub

so I did this

dd if=stage1 of=/dev/fd0 bs=512 count=1
dd if=stage2 of=/dev/fd0 bs=512 seek=1

the floppy was created , and I rebooted with the floppy and this error comes up...

Grub Stage2 Geom Failure

why? what did I do ? the disk1 disk2 dvd disk3 is the same size it was before nothing was changed only fat32 was formated (and or converted) to NTFS.

I need help to solve this, I'm out of ideas on how to solve this problem.

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
lesio1974
post Sep 5 2004, 10:30 AM
Post #2


I Eat C Code for Breakfast
****

Group: Members
Posts: 210
Joined: 8-March 04
From: Chicago, USA
Member No.: 2,544



there is a bug in the kernel that SuSe 9.1 uses (Core 2 had the same problems on some machines) that causes it to write/read incorrect vaules in the partition table when there are NTFS partitions on the hard-drive (you say that FAT32 is converted to NTFS now);

Here you go;

Hope this helps a bit;

g


--------------------
-- The Pole
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2017 - 04:36 AM