Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
> Compilation Error! Help!, rarpd
post Aug 26 2004, 09:14 AM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 13
Joined: 18-August 04
Member No.: 3,576

i've been compiling rarpd .. for a couple of days.. and its always the same error!
i'm getting crazy with this.. 'cause i dont know programming..
i 've been compiling rarp1.0 and 1.1,, just in case one was wrog.. but nop.. both give me the same error..
i 've previously compiled libnet and libpcap (just rarp1.1 needs this)
anyway... both of them apparently without mistake..
but when i compile rarp-- this is what happens:

root@dodo:/usr/local/src/rarpd-1.1# ./configure
checking for libnet library in /usr/ng/lib... not found
checking for libnet library in /usr/lib... not found
checking for libnet library in /usr/local/lib... not found

its not finding libnet libraries. and dispite i give it the option of where to find them.. ( ./configure --with-libnet-lib=/usr/lib ... which by the way is where it is looking.. ) same thing happens when i do a "make"

root@dodo:/usr/local/src/rarpd-1.1# make
rarpd.c: In function `send_rarpreply':
rarpd.c:289: `ARP_H' undeclared (first use in this function)
rarpd.c:289: (Each undeclared identifier is reported only once
rarpd.c:289: for each function it appears in.)
rarpd.c:289: `ETH_H' undeclared (first use in this function)
rarpd.c: In function `process_arp':
rarpd.c:334: structure has no member named `ar_sha'
rarpd.c:335: structure has no member named `ar_spa'
rarpd.c:336: structure has no member named `ar_tha'
rarpd.c:337: structure has no member named `ar_tpa'
rarpd.c: In function `main':
rarpd.c:449: warning: assignment makes pointer from integer without a cast
make: *** [rarpd.o] Error 1

AHHHHH!! i 'm getting crazy!!
'cause the libraries of libnet (libnet.a) are @/usr/lib/ and rarpd.c is loofing for them there.. but the same it says it doesnt find them!!


Go to the top of the page
+Quote Post
Start new topic
post Aug 29 2004, 06:53 AM
Post #2

RMS is my Hero

Group: Support Specialist
Posts: 782
Joined: 6-October 02
From: Trichy,INDIA
Member No.: 29

So if you have installed libnet then,where are your libs.

i gues they are in /usr/local/ try this...

#./configure --libdir=/usr/local/lib --includedir=/usr/local/include --with-libnet-lib=/usr/local/lib --with-libnet-lib-include=/usr/local/include

Make sure that you have both libnet headers and libraries installed in /usr/loca/lib and /usr/local/include.There may be a case where your libnet library is there in /usr/local/lib but it doens't have multiple links to itself.This is essential..

All the best..( I wish could be there at your end)

Hemant Kumar
user posted image
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th March 2018 - 01:36 AM