Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Mandrake 10 And Xmms
axios
post Aug 8 2004, 09:14 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 8-August 04
Member No.: 3,516



Ok I just installed mandrake 10 and yeah I'm a newb. But anyway, I was trying to install XMMS and every time I ./configure it ends with this error

*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

now...taking into consideration this is a free downloaded CD I figured maybe it wasn't isntalled. So, I went online and searched for GLIB, I found the newest version and attempted to isntall it. I unpacked, ./configure, make, make install etc and then I ran the install for xmms again and same error. I tried rebooting just incase the settings hadn't taken effect yet. Still didn't work. Anyone have any suggestions??
Go to the top of the page
 
+Quote Post
Corey
post Aug 9 2004, 07:28 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



Dealing with glib/gtk can sometimes cause a nice few headaches. Right off the bat I will suggest that if you are running Mandrake, then I would use the RPM's that are on the cd's that you download.

I am not fully familier with Mandrake, however, i believe you should be able to issue the following command in Mandrake 10 to install xmms:

urpmi xmms

This should resolve dependancies for you such as GTK and GLIB

As a further explanation to the error below, I believe that if XMMS is looking for GLIB >= 1.2.x, then you need to install 1.2.x of glib/gtk. As far as I know, glib/gtk 2.x is not backwards compatible with apps that require 1.2.x, but i could be wrong. If all else fails, try the 1.2.x versions of glib and gtk.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
axios
post Aug 9 2004, 09:49 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 8-August 04
Member No.: 3,516



Thanks bro, that worked perfectly smile.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th October 2017 - 09:14 PM