Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Need Help For First Time User, can't save into vfat partition as user
jubin
post Jan 21 2003, 03:07 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 13-January 03
Member No.: 318



hi,
I have an win98 OS on my system, and I recently installed Redhat 8.0 on my system. I created a partition of 3GB using fdisk and then used the diskdruid which comes along with Redhat 8.0 to created the linux file system EXT2. After logging in I found I couldn't access the other partitions,which I could with Win98. So after a lot of searching and help from friends I finally was able to mount my other partitions. I added the following lines...

/dev/hdb1 /mnt/win98c vfat defaults 0 0
/dev/hdb5 /mnt/win98d vfat defaults 0 0
/dev/hdb6 /mnt/win98e vfat defaults 0 0
/dev/hdb7 /mnt/win98f vfat defaults 0 0
in etc/fstab file

and then saved it.
I was able to acess my other partitions from /mnt.

I can save data in these partitions as an administrator but not as a user. Can anybody help me here?????
huh.gif


--------------------
jubin tk
when a hammer is the only tool u have, every problem u face resembels a nail
Go to the top of the page
 
+Quote Post
Corey
post Jan 22 2003, 03:14 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



It's kind of hard to explain it here exactly what you need to do, your best bet is to type "man mount" and go down till you see the options for "vfat", you should be looking for "gid" and "uid". They would go next to your "defaults" in your fstab.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
Hemant
post Jan 22 2003, 09:26 PM
Post #3


RMS is my Hero
******

Group: Support Specialist
Posts: 782
Joined: 6-October 02
From: Trichy,INDIA
Member No.: 29



using ,chown -R dir username
should work just fine.but i haven't tried.


--------------------
Hemant Kumar
user posted image
hemant@linuxhelp.net
Go to the top of the page
 
+Quote Post
michaelk
post Jan 23 2003, 08:37 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



Make sure you have write permissions on the directories with the FAT32 filesystems unmounted.

This following will allow any user to read/write.

Change your /etc/fstab entries

/dev/hdxx /mnt/<mountpoint> vfat user,umask=000 0 0
Go to the top of the page
 
+Quote Post
Hemant
post Jan 24 2003, 01:42 AM
Post #5


RMS is my Hero
******

Group: Support Specialist
Posts: 782
Joined: 6-October 02
From: Trichy,INDIA
Member No.: 29



uhhh.. yes chown will not work here.


--------------------
Hemant Kumar
user posted image
hemant@linuxhelp.net
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2017 - 01:00 AM