Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Samba Share - Very Low Transfer Rate
wannabe
post Jul 31 2004, 01:00 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 31-July 04
Member No.: 3,455



Using Samba 3.0.3-5 on Fedora Core 2 with a public share on the FC2 box.
I can see the share fine on my WinXP sp1.
No errors in the logs or from the ifconfig command output.

But, it takes me just under 60 seconds to copy a 1,7mb file on to the share.

So far I tried this list below, with no diffrence I should add:
1. adding these lines to my smb.conf, one at a time with a service smb restart
;socket options = SO_SNDBUF=4096 SO_RCVBUF=4096
;socket options = IPTOS_LOWDELAY SO_RCVBUF=8192 SO_SNDBUF=8192
;socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
2. Disabled IPv6 setting the alias net-pf-10 off in /etc/modprobe.conf
3. Disabled DHCP config in my /etc/sysconfig/network-scripts/ifcfg-eth0
to get rid of the nameserver line in my /etc/resolv.conf from my DSL modem
and used my ISP nameserver instead.

My /etc/samba/smb.conf now looks like this:

[global]
workgroup = WORKGROUP
netbios name = o4_server
server string = o4 Samba
guest account = smbguest
security = share
hosts allow = 192.168.1. 127.
[Storage]
comment = Dump backups here
path = /tmp
guest ok = yes
guest only = yes
read only = no

The logs I'm looking at are:

/var/log/samba/nmbd.log
/var/log/samba/smbd.log
/var/log/messages

Can you pls point me where to go next?
Feeling like I've googled most of the linux forums already - sheesh! unsure.gif

edit: sorry, unable to edit the topic line, hence the "sama" blink.gif

This post has been edited by wannabe: Jul 31 2004, 01:15 PM
Go to the top of the page
 
+Quote Post
Corey
post Aug 2 2004, 07:53 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



I fixed your title for you.

What speed is your network supposed to be run at? 10Mbps or 100Mbps? I used to have problems with my server using samba shares when i had a 10Mbps, but as soon as I upgraded to 100Mbps, everything went a lot faster. I know that 60 seconds for a 1.7mb file is extreamly slow for a 10Mbps network, but still, the upgrade worked a lot better for me.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
wannabe
post Aug 2 2004, 12:06 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 31-July 04
Member No.: 3,455



Go figure, the cables here only do 10Mbps, all the NIC's can do 100Mbps but that's of no use to me at the moment. Guess my next step is to fix the cable ends/wall sockets and see what happens. Thx for the tip!
Go to the top of the page
 
+Quote Post
wannabe
post Aug 5 2004, 03:02 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 31-July 04
Member No.: 3,455



For the record: Well, it works after I put this line in my smb.conf
CODE
socket options = TCP_NODELAY IPTOS_THROUGHPUT SO_SNDBUF 4096 SO_RCVBUF 4096

No idea why. Also, when I added it I started to get these errors(?) in the logs:
CODE
Aug  5 18:22:31 asdf smbd[2362]: [2004/08/05 18:22:31, 0] lib/util_sock.c:set_socket_options(159)
Aug  5 18:22:31 asdf smbd[2362]:   Unknown socket option 4096
Aug  5 18:22:31 asdf smbd[2362]: [2004/08/05 18:22:31, 0] lib/util_sock.c:set_socket_options(159)
Aug  5 18:22:31 asdf smbd[2362]:   Unknown socket option 4096

But I'm going to stick with it, at least until I get my cables fixed. Network util is steady at 55% on my XP pc, using 10baseT-FD settings from pc to switch and from there to the Samba box I'm using 100baseTx-FD. The final smb.conf looks like:
CODE
[global]
workgroup = WORKGROUP
netbios name = asdf
server string = Samba
guest account = smbguest
security = share
hosts allow = 192.168.1. 127.
local master = yes
preferred master = yes
socket options = TCP_NODELAY IPTOS_THROUGHPUT SO_SNDBUF 4096 SO_RCVBUF 4096
[Storage]
comment = Dump stuff here
path = /tmp
guest ok = yes
guest only = yes
read only = no

The local master = yes and preferred master = yes lines made no diffrence btw. Just keeping them to remember some of the stuff I came across.
It's very interesting to see that when I drop the 100baseTx-FD on the Samba box down to 10baseT-FD the network util promptly dops down to around 30%. So in conclusion, using these settings anyway, 10baseT-FD on a Samba server is a no-no.
Go to the top of the page
 
+Quote Post
hughesjr
post Aug 6 2004, 06:12 AM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Mine says:

CODE
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192


so try it with an = between SO_RCVBUF and the number .... and SO_SNDBUF and the number smile.gif

Like this (with your setttings):

CODE
socket options = TCP_NODELAY IPTOS_THROUGHPUT SO_SNDBUF=4096 SO_RCVBUF=4096


Most tuning articles for samba recomend 8192 instead of 4096 for SO_RCVBUF and SO_SNDBUF ... so I would go with:

CODE
socket options = TCP_NODELAY IPTOS_THROUGHPUT SO_SNDBUF=8192 SO_RCVBUF=8192


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
wannabe
post Aug 6 2004, 06:53 AM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 31-July 04
Member No.: 3,455



The logs are clean now. Thx!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 10:17 AM