Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Outer Network (wan) Inbound Problems
JordanF
post Jul 28 2004, 03:27 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 28-July 04
Member No.: 3,440



Hello,

I have a home network where there are 4 windows computers and 1 linux server behind a Linksys wireless router. My linux machine is connected to the network via a DWL 520+ card with an ACX-100 chipset using the open-source drivers for ACX-100 wireless cards. It establishes the wireless connection and all other local network TCP/IP and UDP connections just fine.

I have configured the router to forward SSH and an alternative HTTP port to the linx server (ports 22 and 10065, respectively). Outside users can access services on one of my windows machines OK, but any outside connections to ports that are forwarded to the Linux server timeout. wacko.gif

I have successfully tested port forwarding to my windows computers but cannot successfully get the linux server to accept outside (WAN) connections.

My distribution is Slackware 9.1.0 running the 2.4.22 Linux kernel on an i386 architecture.

Is linux by default locked down to deny connections from IP addresses not in the private class, or am I just missing something? Help is greatly appreciated. smile.gif
Go to the top of the page
 
+Quote Post
adam.stokes
post Jul 28 2004, 06:51 PM
Post #2


./configure
***

Group: Members
Posts: 65
Joined: 22-July 04
From: raleigh, NC
Member No.: 3,403



not quite sure how slackware has its services setup i think it uses System V setup as well but make sure iptables is either turned off completely or set to accept those connects.. something like this


iptables -t filter -A INPUT -s 192.168.0.0/24 -j ACCEPT


--------------------
adam.stokes
Fedora Core rawhide, RHEL WS, ES, AS :)
Red Hat Certified Engineer
Go to the top of the page
 
+Quote Post
JordanF
post Jul 29 2004, 11:10 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 28-July 04
Member No.: 3,440



Thank you for your reply.

I resolved this issue by simply adding my gateway to the routing table. Apparently /etc/rc.d/rc.inet1 wasn't setting up the gateway correctly.

CODE
route add gw 192.168.1.1
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 04:07 PM