Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Help! Suse 9.1 Wont Boot Windows
krankyjoe
post Jul 18 2004, 10:18 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 18-July 04
Member No.: 3,374



I recently (today) installed SuSE 9.1 on my system, dual-booting with winxp home. Linux works fine but it wont boot into windows at the boot loader. I get this error message:

QUOTE
root (ha0,0)
  Filesystem type is fat, partition type 0xc
chainloader +1

NTLDR is missing
Press any key to restart.


I read a similar post on here which directed me to this help page:
Windows No Longer Boots Following the Installation of SUSE LINUX 9.1

I followed the instructions and installed the patch but it did nothing?

My HD looks like this:

/dev/hda
/dev/hda1
WIN95 FAT32 LBA
/dev/hda2
Extended
/dev/hda3
Linux swap
/dev/hda4
Linux native
/dev/hda5
HPFS/NTFS

Windows XP Home is on the Fat32 partition and the NTFS is just data (dont ask how they ended up that way...)

Any help would be much appreciated.
Thanks
Go to the top of the page
 
+Quote Post
hughesjr
post Jul 18 2004, 10:26 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Edit the file:

/boot/grub/grub.conf and look for the windows entry ... it should say something this:

QUOTE
title Windows
        rootnoverify (hd0,1)
        chainloader +1


Or

QUOTE
title Windows
        rootnoverify (hd0,0)
        chainloader +1


Depending on where your boot sectior is for XP....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
krankyjoe
post Jul 18 2004, 10:44 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 18-July 04
Member No.: 3,374



I cant find the grub.conf file???
In the /boot/grub folder there are only these files:

device.map
deviace.map.old
e2fs_stage1_5
fat_stage1_5
ffs_stage1_5
jfs_stage1_5
menu.lst
menu.lst.old
minix_stage1_5
reiserfs_stage1_5
stage1
stage2
vstafs_stage1_5
xfs_stage1_5

Does it possibly need to be created? Sorry if that sounds stupid or something, iam very new to linux.
Go to the top of the page
 
+Quote Post
krankyjoe
post Jul 18 2004, 10:59 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 18-July 04
Member No.: 3,374



In the menu.lst file, there is a place similar to what you were talking about. I edited it and then rebooted.
Still didnt work.
Now the error message reads like this:
QUOTE
rootnoverify (hd0,0)
  Filesystem type is fat, partition type 0xc
chainloader +1

NTLDR is missing
Press any key to restart.


Please Help!!!

Iam gonna try that patch again from SuSE... brb
Go to the top of the page
 
+Quote Post
hughesjr
post Jul 18 2004, 11:01 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



also try the (hd0,1)


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
krankyjoe
post Jul 18 2004, 11:21 PM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 18-July 04
Member No.: 3,374



there is no hd0,1 in the file, just the hd0,0
Go to the top of the page
 
+Quote Post
krankyjoe
post Jul 19 2004, 12:20 AM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 18-July 04
Member No.: 3,374



Tried that patch again, no luck. Is there mabey a way to get around the boot loader and just boot into windows?
Go to the top of the page
 
+Quote Post
hughesjr
post Jul 19 2004, 05:20 AM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



(hd0,1) is the second partition on hda ... hda2, where I think your XP install is.

change the (hd0,0) to (hd0,1) and save then try it.
-----------------
You can reinstall the WinXP bootloader by booting to the repair console (using the XP boot disk) and using the command:

fixmbr

See these links:
Boot to console

fixmbr

Then Linux won't boot ... but you can use bootpart to setup the linux boot


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
hughesjr
post Jul 19 2004, 06:42 AM
Post #9


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Don't do the fixmbr thing right now (it could screw up your drive) .... unless you make sure that you don't have the 2.6 kernel problem ...

Go into your BIOS and pick LBA as the access mode ... or try the patch again ... if those don't work, as a last resort, try the fixmbr.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
krankyjoe
post Jul 19 2004, 03:29 PM
Post #10


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 18-July 04
Member No.: 3,374



I changed the hd0,0 to hd0,1, it altered the error message a bit but still wont let me in.
I tried the SuSE patch again after the edit and there was no effect.
Looked in my BIOS for the LBA setting, doesnt seem to have it, since its a laptop there are not many options in the BIOS.
I'am a little scared to try that fixmbr thing because I really dont want to loose the drive.
Are there ANY other options? Or should I just close my eyes and try to use the fixmbr thinger?
Thanks again for your help.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 01:53 PM