Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Firefox Install Problem - Child Process?, Have I done it wrong?
skinfreak
post Jul 10 2004, 01:39 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 10-July 04
Member No.: 3,319



Hello!

new to this Linux stuff (Mandrake 10) and I am getting a bit hot and bothered about installing software. I thought I had successfully installled Firefox (followed the instructions), under root but when it comes to running it I get this error;

Failed to execute child process "/usr/src/firefox" Permission denied

Dunno...tried chmod the executable file but to no avail. It doesn't work in either root or my main account.

On a similar level, I have installed Opera 7.52 and can only run it when logged in as root, and not my main account. I have tried changing permissions but it hasn't helped...both prgs are installed to usr/src. The firefox file is;

firefox-0.9.1-i686-linux-gtk2+xft-installer

Any ideas? Thanks in advance!
Go to the top of the page
 
+Quote Post
hughesjr
post Jul 10 2004, 04:14 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



As a general rule of thumb ... you should put code you install from into /usr/src/dir_name ... and you should put installed code in either:

/usr/lib/dir_name

or

/usr/local/lib/dir_name

or

/opt/dir_name

---------
In the case of FireFox...there is a build already integrated into Mandrake 10 official (it is mozilla-firefox-0.8-14mdk).

Whichever Distro you use, I would recommend that you use that Distro's own method to install software and updates, and to use the programs available from that distro first ... and manually install software (like firefox) only if the Distro doesn't provide it.

If you haven't already setup Mandrake 10 to be able to get updates from Mandrake, I recommend that you do so following this post.

After you have configured urpmi, you can install FireFox for Mandrake 10 with the command:

urpmi mozilla-firefox

It will then be on the menu under Internet -> Web Browsers ... you will need to logout and back in to see it in the menu.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Termina
post Jul 10 2004, 04:52 PM
Post #3


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



Also, the new version of firefox does not need you to use the method described in the guides forum.

It has an install script which does everything for you


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 14th December 2017 - 03:01 AM