Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Random Shutdown
wolfsta
post Jun 10 2004, 06:54 PM
Post #1


Grub-er
**

Group: Members
Posts: 30
Joined: 20-November 03
Member No.: 1,836



Hey all

Was just at work happily browsing the net and then nothing.

My linux gateway shutdown i found out after pinging from every office i went to check and it was off... no one turned it off or anything..

I checked the log after i turned it back on and i think this is the point where it turned off..

Jun 11 11:51:04 red1 apmd[2257]: System Suspend

am i right? and wat is it?

also i want to move all my dhcp related loggin out of messages can goto /dev/null or into a separate log i dont need it but how do i do it?

Cheers smile.gif
Go to the top of the page
 
+Quote Post
dlab
post Jun 17 2004, 02:44 AM
Post #2


Grub-er
**

Group: Members
Posts: 30
Joined: 16-June 04
From: California, USA
Member No.: 3,175



I think the autosuspend is controlled by your BIOS, and you'd have to disable it there. Apmd just reports on this info and it can execute a command when something happens.


--------------------
The computer is the ultimate polluter, its s__t is indistinguishable from the food it produces.
user posted image--Found somewhere in the Fortune game.
Go to the top of the page
 
+Quote Post
hughesjr
post Jun 17 2004, 06:01 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Yes, the computer was set in the BIOS to allow suspending ... and your linux understood the APM setup, so it suspended. You can turn off suspend mode in the BIOS ... and / or you can tell the Linux Kernel not to use APM. On a server, you should probably do both...

You can tell the computer not to suspend by passing apm=off in on the kernel line. You didn't say what distro you are using ... but if it uses grub as the bootloader, put this at the end of the kernel line:

apm=off

in the file /boot/grub/grub.conf
...........
If you use LILO as your bootloader open the file /etc/lilo.conf, and find the section you boot from, then add:
apm=off

inside the :

append = " "

line of that section. Save lilo.conf, then run the command:

lilo
....................
Everything needs to be done as root


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th December 2017 - 08:15 AM