Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Xconfigurator, HELP!!!!!(newbie)
bayou75
post Jan 6 2003, 03:42 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 6-January 03
Member No.: 294



ive just installed red hat 7.0 on my computer...on a second hard drive...i cant get a gui....ive tried..X startX ....Xconfig
......which when i try to run x or startx it says...no screens found..and takes me back to text.....on Xconfigurator..my monitor is shown there...is a acerview 11d svga...i select it..it probes and says it didnt find it to manually set up my graphics card...my graphics card is a nvidia geforce2 mx 200....ive tried almost all options and the same...it takes me back to the begining of xconfig....ive tried generic multi sync....and same...when i try SuperProbe...it tells me generic vga....anyhow..as you can see i have some probs...if anyone can help i would greatly apreciate it.....
Go to the top of the page
 
+Quote Post
null
post Jan 6 2003, 05:10 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 6-January 03
Member No.: 291



have you actually installed a gui environment. If you chose a server install, it might not have installed a gui. You may have to try different resolutions to get it to work

null
Go to the top of the page
 
+Quote Post
Corey
post Jan 8 2003, 09:35 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



It's weird that Redhat 7 didn't automatically configure and set up your X server perfectly for you. In my experiences, Redhat has done a great job of this since probably v6.2. The only other thing I can suggest is to do it manually:

as root:

[quote]XFree86 -configure[/quote]

this will create a file called /root/XF86Config with a whole lot of defaults. From there, you can edit the file. Check your monitor manual for the Horizontal Sync range and Verticle Refresh range, you will need this. Now, go into the above file, and edit the Monitor section and add the following lines (of course, fill in the values from your monitor manual):

[quote]
HorizSync 30-54
VertRefresh 50-120
[/quote]

Next, check your Input settings for your mouse, make sure you set up your wheel mouse, or usb, or whatever you have. Now, go to your device section, and make sure that it's using the Driver "nv". (if you want hardware acceleration, download the modules from NVidia's website first, and replace "nv" with "nvidia").

Now, work your way down to "Screens" section, if you want a default color depth of 16, then your Screens should look something like this:

[quote]
Section "Screen"
   Identifier  "Screen 1"
   Device      "Device1"
   Monitor     "Monitor1"
   DefaultDepth    16
   SubSection "Display"
       Depth       16
       Modes       "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
       Depth       24
       Modes        "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
       Depth       32
       Modes       "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection
[/quote]

Of course, if you're like me, and you cannot support anything above 1024x768, then erase all the values above that are no good for you. After that's all done, save the file, and copy it to /etc/X11/XF86Config-4 . Now, try to start your X server. Let me know what happens and any additional questions.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 12th December 2017 - 11:08 AM