Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Redhat 8 Cd Audio Problem, CD audio isnt output.
null
post Jan 6 2003, 11:04 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 6-January 03
Member No.: 291



Hey there,

I've recently installed a clean copy of Redhat 8.0, workstation, with a copy of extras picked from custom package selection. Everything is fine, picked up all my hardware and looked good!

Sound is working fine. It will play wav,mp3,wma,ogg and the like, but refuses to play audio cd's. Before someone pipes up, YES the audio cable is connected to the M/B, and both cdroms (one a dvd - the default, one a cd-rw) play fine in windows XP (on dual boot). One drive, the dvd-rom is DMA enabled, the other isnt.

When an audio cd is inserted into the dvd drive, the drive spins up, the cd player is fired up, and it correctly identifies the CD through CDDB, and starts playing it. The counter happily goes up, but you cant hear a thing. The volumes are all set right, and nothing happens when configured to use the other drive instead.


Anyone got a clue? It's doing my head in, because this is the only format it wont play sound with. I read somewhere that if DMA is enabled, it can extract the audio digitally over the bus, but obviously this doesnt happen either.

It's a shame because I was soooo impressed with the latest build.


Thanx for any comments


null


p.s. This occurs under gnome and kde, using the default gnome cd player, kscd and xmms.
Go to the top of the page
 
+Quote Post
Corey
post Jan 6 2003, 12:37 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



This definitly sounds like a mixer problem. Obviously if it works in XP, then it's not a hardware issue (ie. cables, etc.). I believe Redhat installs with Alsa enabled, so you should open up a console, and type "amixer", that will bring up your alsa mixer. Scroll over and make sure that there are no cd-player mixer channels on mute (ie. volume all the way down), you can fix it there if any are down, and exit out with Esc.

That should do it, I can't see any other reason for it. (Maybe try a few different programs).


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
null
post Jan 6 2003, 03:06 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 6-January 03
Member No.: 291



Hi,

Thanks for your reply. I've check the mixer setttings, and have set the whole lot to max. None are on mute, and i presume the 'lock' option does something other than prevent audio cd playback.

Once again, thanks for your suggestions - i'm as miffed as you are!

null
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th December 2017 - 06:37 PM