Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Problem Installing Nvidia Drivers, Unable to determine...module filename...
danep
post May 20 2004, 12:27 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 20-May 04
Member No.: 2,994



When trying to install the latest NVidia drivers, I get the error:

"Unable to determine the NVIDIA kernel module filename" blink.gif

I have no idea what to do. I already had to reinstall the kernel source code to even get this far, now I'm completely lost! smile.gif

[edit] I'm running SuSE 9.0, kernel v2.4.21. I've tried using the --kernel-source switch, and verified that the symbolic link /usr/src/linux is working, to no avail.[/edit]
Go to the top of the page
 
+Quote Post
Robert83
post May 20 2004, 12:39 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

make sure that the kernel source you've downloaded does not contain any cutsom in the version line

I think it is /usr/src-[kernel-version]/Makefile

(sorry doing this from a WinXP computer)

please check the first few lines of the Makefile, those about the version information , and make sure that your kernel source and kernel version match(?).

usualy you install the nvidia driver
by downloading the driver from www.nvidia.com
download the kernel source for your current kernel
modify the init level to 3 in /etc/inittab
reboot
and type ./NVIDIA-[blablabla]
and it should install without any errors

your error is likely because your Makefile in the kernel source directory contains a custom word in it's version number, or you don't have the correct kernel source (it must be the same as your kernel version).
Since you said that you have the correct symbolic link , then that shoudn't be the problem , I mean the symbolic link to the source.

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
danep
post May 20 2004, 01:46 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 20-May 04
Member No.: 2,994



The first few lines of the Makefile are:

VERSION = 2
PATCHLEVEL = 4
SUBLEVEL = 21
EXTRAVERSION = -$(CONFIG_RELEASE)-$(CONFIG_CFGNAME)

KERNELRELEASE=$(VERSION).$(PATCHLEVEL).$(SUBLEVEL)$(EXTRAVERSION)


uname -r gives a kernel version of 2.4.21-215-smp4g, which more or less matches the (rather convoluted) entry in Makefile. Does this look correct?
Go to the top of the page
 
+Quote Post
Robert83
post May 20 2004, 02:20 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

it seems that the kernel version doesn't mach the kernel source, that is not good, you should download the kernel source which is the same version (exactly the same version) as you kernel.

That is causing the problem with the NVIDIA installer.

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
danep
post May 20 2004, 06:23 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 20-May 04
Member No.: 2,994



?? It looks to me like the kernel does match the source, I'm not sure what you mean. Apart from those vague last two lines, the source indicates version 2.4.21, which matches the kernel.

Plus, I downloaded the source using YaST, so it should have automatically matched it to my existing kernel.

Thanks for your help, but still very confused smile.gif
Go to the top of the page
 
+Quote Post
hughesjr
post May 20 2004, 06:32 PM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



If you used YAST, it should be the same.

Are you using the NVIDIA-Linux-x86-1.0-5336-pkg1.run file?

Do you have a Nvidia NFORCE2 chipset Motherboard?


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
danep
post May 20 2004, 06:45 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 20-May 04
Member No.: 2,994



That's exactly the file that I'm using to install the drivers. I'm not sure what the motherboard is, as it came included with my compy (it's a Sony Vaio), but I'm pretty sure it's some generic Intel chipset, definitely nothing NVidia. Is an Nvidia chipset motherboard required for it to work correctly??
Go to the top of the page
 
+Quote Post
hughesjr
post May 20 2004, 07:29 PM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



No, the NFORCE2 chipset actually doesn't work with the 2.4.21 kernel.

As root (from a console) in the directory tht contains the NVIDIA file try these lines:

chmod 755 NVIDIA-Linux-x86-1.0-5336-pkg1.run
IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-5336-pkg1.run


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
hughesjr
post May 20 2004, 07:33 PM
Post #9


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



On thing that looks wierd is the smp4g kernel ... is this a dual processor machine (or a P4 with hyperthreading)?


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
danep
post May 20 2004, 08:07 PM
Post #10


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 20-May 04
Member No.: 2,994



QUOTE
No, the NFORCE2 chipset actually doesn't work with the 2.4.21 kernel.
LOL! Good thing, then.

Yup, it's a P4 w/ HT.

QUOTE
chmod 755 NVIDIA-Linux-x86-1.0-5336-pkg1.run
IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-5336-pkg1.run


I tried those lines and it didn't seem to change anything at all sad.gif I still get that error, and below it the line
ake: *** [select_makefile] Error 1

BTW, thank you everyone so far for you helpful and swift replies smile.gif
Go to the top of the page
 
+Quote Post
hughesjr
post May 20 2004, 08:41 PM
Post #11


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



No problem with the smp kernel then ....

I am using the NVIDIA drivers on the SUSE 2.4.21-215-default kernel right now with no problems at all .... (my test box is a pIII 800 w/ 768mb RAM and a GeForce2, so the default kernel and not the smp kernel is installed).

Try this:

cd /usr/src/linux
cp /boot/config-2.4.21-215-smp4g .config
make oldconfig
make dep


Then go back to the directory containing NVIDIA-Linux-x86-1.0-5336-pkg1.run and redo the command:

IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-5336-pkg1.run


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
danep
post May 20 2004, 08:59 PM
Post #12


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 20-May 04
Member No.: 2,994



It didn't seem to have any affect, hughesjr

Here's the log from the installation, if it helps:

CODE
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu May 20 20:55:18 2004

option status:
 license pre-accepted    : false
 update                  : false
 force update            : false
 expert                  : false
 uninstall               : false
 driver info             : false
 no precompiled interface: false
 no ncurses color        : false
 query latest driver ver : false
 OpenGL header files     : false
 no questions            : false
 silent                  : false
 XFree86 install prefix  : /usr/X11R6
 OpenGL install prefix   : /usr
 Installer install prefix: /usr
 kernel source path      : (not specified)
 kernel install path     : (not specified)
 proc mount point        : /proc
 ui                      : (not specified)
 tmpdir                  : /tmp
 ftp site                : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
  4496).  As part of installing this driver (version: 1.0-5336), the existing
  driver will be uninstalled.  Are you sure you want to continue? ('no' will a
  bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
  ke the installer to attempt to download a kernel interface for your kernel f
  rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
  this means that the installer will need to compile a kernel interface for
  your kernel.
-> Kernel source path: '/usr/src/linux'
-> Performing cc_version_check with CC="cc".
ERROR: Unable to determine the NVIDIA kernel module filename.
ERROR: Installation has failed.  Please see the file
      '/var/log/nvidia-installer.log' for details.  You may find suggestions
      on fixing installation problems in the README available on the Linux
      driver download page at www.nvidia.com.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 03:39 PM