Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> What Do You Think About Recording?, mdk 10 cmty, krec, aRts, mic'd input
jeff_brown
post May 8 2004, 11:56 PM
Post #1


Grub-er
**

Group: Members
Posts: 48
Joined: 12-February 04
Member No.: 2,361



Hello, intrepid fellow explorers of man's great technological wilderness!

Everything one might need in order to record, I have working -- yet I cannot record. I'm using KRec, and hence aRts, in Mandrake 10 Community.

Most of this email I'm going to spend giving my story. However, you don't have to read it -- if you've successfully done sound or music on Linux and you have particular arrangements to recommend, you can skip my trials and just tell me what's worked for you, and I'll feel very helped!

------------ The setting: ------------
I can send my voice through the PC speakers, via Line in. The sound quality is stunning.

I've been taking the advice of the lesson in KDE Help Center's entry for KRec. It says I must assign Capture: On to the Line in. I can.

It also describes requirements for aRts. First, from arts-control, audio manager should show KRec::In is set to the in_soundcard bus. It is.

Next, KRec needs arts "on" and in full-duplex mode. Here might lie my first problem, because I can't determine whether aRts is "on" or in full-duplex mode. The K Control Sound Server page, which is supposed to, doesn't mention aRts at all (nor ALSA or LADSPA or OSS or any of those things it used to configure in Mandrake 9.1).

However, I'm pretty sure aRts works, because I can do all sorts of stuff with it: The aRts Control tool will show a picture, or even a bouncing EQ graph, of music files from the PCM channel; from there I can run the FreeVerb effect on the music in real time (although the vocal Line input receives no effect); I can even use aRts shell commands, like "artsshell volume x" to multiply the volume by a factor of x.

So aRts seems to work. And if it does, then everything works -- but the dang machine won't record!

------------ The problem: ------------
According to the KDE Help Center Tutorial, "if everything worked you should now see something colorful moving inside KRec -- the VU-Meter showing how loud your recording is. The slider to the right of the VU-Meter controls the volume." There's no such thing. There *is* an empty gray space, to the right of which a slider can move in [0, 200]. However, mic'd signals yields nothing in KRec. I can go through the motions of recording, in which case it will create a file, but on playing that file sox hurls:

sox: bad input format for mic.raw*: sample rate was not specified

(I think it was .raw, but it could have been .wav. Sorry -- I'm stukk in Windows now.)

------------ So tell me ... ------------
Has anyone else run into aRts problems in Mdk 10? If you've got no ideas on that, can you recommend an alternate method of recording? Does Mandrake 10 Official have a similarly deficient KControl Sound Server panel? If not I'll upgrade in a second. Or if you've had better sound experiences with other distributions, tell me and I'll try those. I'm really open to suggestions -- I've got all summer to bathe in these programs.

I've already had JACK suggested, and I plan to install it -- but it's a sound server, hence it's got massive requirements, hence I'll probably eat pavement again, hence I'd like to at least give aRts a serious shot first.

Any help is INCREDIBLY, ABSURDLY appreciated.


--Jeff Brown
Go to the top of the page
 
+Quote Post
Jim
post May 9 2004, 12:14 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



Try audacity, I have used it on my mac and it works pretty well. I haven't tested the linux version yet but I would asume it works pretty much the same.

I would aslo go back and make double sure you got your modules for your sound card in right. What kind of sound card is it? Most sound cards will work by defualt with a generic module, but if you really want it working right, you need to make sure that the correct module is loaded.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
hughesjr
post May 9 2004, 04:43 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



I have used audacity on linux and it is pretty good.

I don't normally use KDE, but I'll see if I can get KRec to run on my test install on Mandrake 10.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 01:51 PM