Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Linux Patches How To, Where can I find patchs ?. How to apply?
reddy_k_s
post Dec 31 2002, 04:04 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 31-December 02
Member No.: 276



Hi,

I have Oracle 8.1.7 running on
Red Hat Linux release 7.0 (Guinness)
Kernel 2.2.16-22smp on an i686.

I need help with these 3 tasks:
Task 1. Change server name (IP address remains the same).
I am looking for info. on how to change server name.
Does server name change effect Oracle functionality?
If yes, what do I have to do to correct it.


For below mentioned services I was told "Port is open"
I want to know how to close ports.
Just in case I close a wrong port or a required port
I also want to know how to open a closed port.

general/tcp
ssh (22/tcp)
telnet (23/tcp)
smtp (25/tcp)
finger (79/tcp)
sunrpc (111/tcp)
auth (113/tcp)
login (513/tcp)
shell (514/tcp)
printer (515/tcp)
submission (587/tcp)
unknown (1521/tcp)
unknown (1024/tcp)
unknown (1025/udp)
unknown (1024/udp)
sunrpc (111/udp)
ftp (21/tcp)


Task 3. Apply patches (security patches).
Where can I get OS patches ?
Where can I get instructions on how to apply patches ?
If I run into problems is there a forum or website for help.

Some of the reasons for upgrade. I am not sure wh

Service : ssh (22/tcp)
You are running a version of OpenSSH older than OpenSSH 3.2.1

A buffer overflow exists in the daemon if AFS is enabled on
your system, or if the options KerberosTgtPassing or
AFSTokenPassing are enabled. Even in this scenario, the
vulnerability may be avoided by enabling UsePrivilegeSeparation.

Versions prior to 2.9.9 are vulnerable to a remote root
exploit. Versions prior to 3.2.1 are vulnerable to a local
root exploit.

Solution :
Upgrade to the latest version of OpenSSH

Risk factor : High
CVE : CAN-2002-0575


Service : submission (587/tcp)
The remote sendmail server, according to its version number,
may be vulnerable to the -bt overflow attack which
allows any local user to execute arbitrary commands as root.

Solution : upgrade to the latest version of Sendmail
Risk factor : High
Note : This vulnerability is _local_ only


This list goes on .......


Thanks
Reddy [HTML]
Go to the top of the page
 
+Quote Post
chrisw
post Dec 31 2002, 04:19 PM
Post #2


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



at your command line type:

setup

the select services configuration
and the select which services you want to
have started on boot-up

then just reboot your computer and all will be ok.

if you want to start and stop services

go to our /etc/rc.d/init.d directory

and just stop each service you want to stop
for example...your ssh service..you would type:

/etc/rc.d/init.d/sshd stop
to stop the service

and /etc/rc.d/init.d/sshd start
to start the service

as far as updates i think redhat started
a program called up2date

its easier if you are in a graphical environment also

while in gnome or kde

open a terminal window and type:

up2date

and follow the directions....its pretty easy to use


thats about it...


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
reddy_k_s
post Jan 2 2003, 09:48 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 31-December 02
Member No.: 276



Thanks for the response.
I tried following commnads
/etc/rc.d/init.d/smtp stop
/etc/rc.d/init.d/ftp stop
/etc/rc.d/init.d/sendmail stop

first 2 services are not there at all. I got an error message.
But to my surprise they are still active some where.

Last one "/etc/rc.d/init.d/sendmail stop"
After executing the above command, I got
stop....... User unknow on the screen.
No response from last 30 minutes. (No command prompt).
I think there is some thing wrong. Any help.

Thanks
Reddy
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2017 - 09:54 AM