Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Samba Nightmare!
neilofcov
post May 6 2004, 10:41 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 6-May 04
Member No.: 2,896



Hi,

I have mounted a network drive as root using the command :
mount -t smbfs -o username=administrator,password=neilofcov //norlabackup/linuxshare /mnt/data

All of the data on the network drive is now accessible in the /mnt/data folder and can be edited etc by root. I then set up a SAMBA share for this directory. I can map the directory to my windows xp pc fine but only have read access permission. I've tried chmod 777 data but this give the error - chmod: changing permissions of `data' (requested: 0777, actual: 0755): Operation not permitted.

I've pasted my smb.conf file into the next post as this one is too long.

Any help to get write access to this would be appreciated.

Many Thanks,

Neil.

# Samba config file created using SWAT
# from NORLA-SPARK (127.0.0.1)
# Date: 2004/05/06 15:44:17

# Global parameters
[global]
workgroup = NORLACOVENTRY
server string = samba server
security = SHARE
encrypt passwords = Yes
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %nn *Retype*new*password* %nn *passwd:*all*authentication*tokens*updated*successfully*
unix password sync = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = No
directory mask = 0777
force directory mode = 0777
guest ok = Yes
printing = cups

[homes]
comment = Home Directories
valid users = %S
read only = No
create mask = 0777

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[spark]
comment = Norla Spark
path = /usr/local/spark
read only = No

[data]
comment = norla data
path = /mnt/data
read only = no
Go to the top of the page
 
+Quote Post
hughesjr
post May 6 2004, 06:46 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Before you mount, make sure the directory is set to 777 ... once you mount, you can't change permissions.

use this instead:

mount -t smbfs -o username=administrator,password=neilofcov,dmask=777,fmask=777 //norlabackup/linuxshare /mnt/data

see man smbmount for other mount options like uid, gid


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
neilofcov
post May 7 2004, 04:11 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 6-May 04
Member No.: 2,896



Thank hughesjr biggrin.gif It's working fine now.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 10th December 2017 - 11:02 PM