Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Mail Server Problems
dcroxton
post Apr 28 2004, 12:39 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 28-April 04
Member No.: 2,847



I'm not stupid, but I often feel like it when working with Linux. smile.gif I'm running ArkLinux 1.0 Alpha 10, and I have an Apache server that works fine (http://68.41.131.246/derekwiki). What I'd like to do, ultimately, is get an imap server working on the same box so that I can access my email from anywhere, but I'd be happy at the moment just to be able to send and receive mail using pop & smtp. I have spent considerable time reading about email on Linux, and, honestly, I'm still so confused that I hardly even know what to ask. What I'd like to do is explain my situation as much as I can, and hopefully someone can figure out what additional information I need to provide in order to get some useful help.

I use a cable modem that has had the IP address 68.41.131.246 for as long as I was paying attention to it, and I have my firewall/router pass through the relevant ports (and probably a number of irrelevant ones smile.gif ) : 25, 110, etc. I'm guessing, therefore, that my email address would be username@68.41.131.246, or username@localhost.localdomain for local mail. I can't get either to work at this point. When I go to send mail, the mail client (I've tried mutt and KMail) typically says the mail was sent successfully (sometimes not, depending on my current configuration, but it's not objecting at the moment). However, the mail never gets anywhere -- not to accounts on the local machine, and not to my outside account.

I have installed Postfix and tried various edits on main.cf. It's kind of a long file, but I can post all or part of it if that would help. In Webmin, I have a long and accumulating list of messages in the Mail Queue, but all user mailboxes are empty. For mailboxes, I have it set to ~/Mail, which does exist for the users I have been experimenting with. When there is an error sending mail, I can see the messages in the outgoing folder, so I know this is working at least partially.

It appears that smtp is working, at least for local addresses. I can telnet to port 25. However, I cannot telnet to port 110, even though I do have a pop daemon running. I understand the concept of a daemon fine, but I have no clue what xinetd does, so I don't know whether I need to edit the scripts in xinetd.d, or just run a daemon, or what. The mail log consistently shows the following error:
"Apr 28 13:55:25 localhost postfix/master[10803]: warning: process /usr/libexec/postfix/local pid 31123 exit status 1
Apr 28 13:55:25 localhost postfix/master[10803]: warning: /usr/libexec/postfix/local: bad command startup -- throttling."

I hope this gives some Linux guru enough to go on, at least to ask more questions about config or log files to find out what I'm doing wrong. I've been getting pretty comfortable with Linux, but this aspect of it has me completely baffled, so I will be very grateful for any help people can provide.

Sincerely,
Derek
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 03:57 PM