Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Installing 2jsdk On Suse 9.0, Trouble completing installation
ryagami12
post Apr 16 2004, 09:05 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 16-April 04
Member No.: 2,787



installed the Sun J2SDK on my SuSe 9.0 Linux and tried to run a simple Java progam without success at step 2 below.

HelloWorld.java Program:

public class HelloWorld {
public static void main(String[] args) {
System.out.println("Hello World!");
}
}

Step 1: ran ./javac HelloWorld.java successfully
Step 2: unsuccessful at running ./java HelloWorld

Error Message: Exception in thread "main" java.lang.NoSuchMethodError: main

Also tried to load J2SDK on Windown XP and got the same error message.

Tried loading Java library in SuSe, but didn't help.
Go to the top of the page
 
+Quote Post
Jim
post Apr 16 2004, 11:24 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



I don't think the code is getting compiled right. Your code is good, thats not the problem, but I think you know that. Where there any errors durring the install? How did you install it? Source or RPM?

The java error you are getting back it the kind of error you would get it the method hadn't been declaired right, but you did so it doesn't help us figuer out whats wrong with the install.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 11:21 PM