Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Rpm Package Add/remove Program Problem, PLEASE HELP!!!!
familymann
post Apr 15 2004, 01:49 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 15-April 04
Member No.: 2,779



Ok, here is my problem.

I am attempting to install GTK+ (included in my RedHat 9.0 Distro) with a few more Gnome development tools (I thought I already installed when I installed the full package.) These are required by every app I have downloaded and installed. Thought it was fixed, now getting errors saying "GTK+ 2.0 NOT INSTALLED" sometimes I get this error, sometimes I don't. For instance, if I install a 3rd party RPM, the system says I already have that GTK+2 installed. If I then go to install a program, it says it cannot find it. Then, when I attempt to install it from the CD, I get the below errors within the Add/Remove program manager.

(big red X) Packages Not Found

Unlocateable package Required by

gtkhtml = 1.1.8-5 gtkhtm-devel
gdk-pixbuf = 0.18.0 gdk-pixbuf-devel
gdk-pixbuf-gnome 0.18.0 gdk-pixbuf-devel
Xfree86-libs = 4.3.0-2 Xfree86-devel
Go to the top of the page
 
+Quote Post
hughesjr
post Apr 15 2004, 06:00 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Once any updates (or third party RPM packages) are installed, the Add/Remove Applications tool from RedHat is pretty much worthless. (It only understands the versions contained on the CDs, if you have any dependancies not on the original installation CDs, it chokes.)

If you have a broadband internet connection, I would recommend that you use apt from freshrpms as your package management tool.

If you want to do that, download from here:
http://ftp.freshrpms.net/pub/freshrpms/redhat/9/apt/

(pick the top file)

then install with the command:
rpm -Uvh apt-0.5.5cnc6-fr1.i386.rpm

edit the file /etc/apt/sources.list and replace all the lines in the file with these lines:
CODE
# Red Hat Linux 9
rpm http://ayo.freshrpms.net redhat/9/i386 os updates freshrpms
                                                                                                                         
### Dag Apt Repository for Red Hat Fedora Core 1 (rhfc1)
rpm http://apt.sw.be redhat/9.0/en/i386 dag
                                                                                                                         
#newrpms.sunsite.dk
rpm http://newrpms.sunsite.dk/apt/ redhat/en/i386/9.0 newrpms
                                                                                                                         
#ATrpms
rpm http://apt.physik.fu-berlin.de redhat/9/en/i386 at-testing at-bleeding at-good at-stable


Then issue the commands:

apt-get update
apt-get dist-upgrade


After that, issue the command:

apt-get install synaptic

Now you can install many packages (including 3rd party ones) directly via synaptic. You can also use synaptic to keep your product updated.
-----------------------
Some packages that require compiling require devel packages to be installed on your system (these are packages that contain the source code for installed libraries, so that other programs can use the source code and compile in support). These packages are not normally required if you install RPM packages.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
familymann
post Apr 15 2004, 07:51 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 15-April 04
Member No.: 2,779



ok, new problem. When I attempt to install the downloaded RPM package you suggested. I receive the following error.

/sbin/ldconfig: File /usr/lib/libartsgui.so.0.0.0;40763381 is too small, not checked.


Boy. I am really screwed arent I.
Go to the top of the page
 
+Quote Post
hughesjr
post Apr 15 2004, 08:04 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



wierd ...

type:

init 3

(this will take you to the Console ... no GUI ...), then try the install.

You will need to print the instuctions first!


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
familymann
post Apr 15 2004, 09:50 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 15-April 04
Member No.: 2,779



I figure since I just installed on this machine, will just format, reinstall RedHat. This time, I will do full install. No messing around. I should not have been expiramenting.



Thanks for your help though.
Go to the top of the page
 
+Quote Post
hughesjr
post Apr 16 2004, 06:09 AM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



After an install of RedHat ... the first thing I do is add apt and if you like gui package managers, synaptic.

You might consider using Fedora Core 1 as well (if you like the RedHat installs) ... because, in a couple weeks, RedHat Linux 9 will no longer get bugfixes/security updates as it is being de-supported by RedHat.

If you use Fedora Core 1, the apt download page is:
http://ftp.freshrpms.net/pub/freshrpms/fed...ra/linux/1/apt/

the command is:
rpm -Uvh apt-0.5.15cnc3-0.1.fr.i386.rpm

and the /etc/apt/sources.list is
CODE
# Fedora Linux 1
rpm http://ayo.freshrpms.net fedora/linux/1/i386 core updates freshrpms

### Dag Apt Repository for Red Hat Fedora Core 1 (rhfc1)
rpm http://apt.sw.be redhat/fc1/en/i386 dag

#newrpms.sunsite.dk
rpm http://newrpms.sunsite.dk/apt/ redhat/en/i386/fc1 newrpms

#ATrpms
rpm http://apt.physik.fu-berlin.de fedora/1/en/i386 at-testing at-bleeding at-good at-stable


after the install and changing /etc/apt/sources.list ... the updates are the same.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 03:44 PM