Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Multiboot Redhat 7.3 + Winxp Pro Help (n00b), Need advice on creating partitions
Kyoushu23
post Dec 20 2002, 08:44 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 20-December 02
Member No.: 259



Hey all, Im not sure if this setup will even work or not but here is what im looking at...

I had 2 HD's in this system, primary drive crashed, secondary drive is where my existing WinXP installation resides, I just purchased a new 80gb HD to replace the primary drive that failed and created a 70gb fat32 partition. and decided to use the remaining 10gb of space for a RedHat7.3 installation.

I need some help with creating the partitions to install redhat, I followed the instructions provided in the user manuals and created a 50mb /boot partition, a 2048mb swap partition and then used the remaining space (roughly 8gb) for the installation.

When it came to installing the boot loader I selected LILO and installed it to the 50mb partition. I waited roughly 20min while the installer copied everything over, then when prompted, removed cd's and rebooted pc.

I now get a blinking cursor followed by a line of text that reads "No OS Installed" I can press a key and it will continue past this message and boot WinXP which loads fine. I tried using the bootdisk the installation created but recieved the same error.

Im wondering if I created the partitions incorrectly, or if I should be installing LILO/GRUB to the mbr of the windows xp drive or if im just doing everything completely wrong.

Any help with creating these partitions or suggestions of something to try would be appreciated greatly.




(sorry for the long rambling post as well, Im a total newbie so if I missed any vital info let me know)
Go to the top of the page
 
+Quote Post
Corey
post Dec 20 2002, 12:22 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



I'm probably going on old information here, this might have changed in newer versions of lilo, however, I believe that you must install lilo in the first 1024 cylinders of the hard drive in order for it to work properly. My suggestion is to install lilo into your MBR. I have never had a problem with this method, and I believe Redhat even sets up your WinXP automagically as well, so when it comes to the boot screen, you'll have both Redhat Linux and Windows XP listed there. Give that a try and see how you fair.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
Hemant
post Dec 27 2002, 05:25 AM
Post #3


RMS is my Hero
******

Group: Support Specialist
Posts: 782
Joined: 6-October 02
From: Trichy,INDIA
Member No.: 29



hi..
there r two solution to this
1.simply install grub on the mbr evrything else will be taken care by
grub.
2.install lilo on your boot partition and than copy your bootsect.lnx to
to c drive of windows and edit the boot.ini file there
and and following lines there
c:\ootsect.lnx="Linux"
i have tried both of this and they worked fine.


--------------------
Hemant Kumar
user posted image
hemant@linuxhelp.net
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 07:06 AM