Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Puzziling Cd Writer Problem, CD Writer burns unmountable disks?
cfalcon
post Apr 12 2004, 10:43 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 5-September 03
Member No.: 1,384



A while ago, my machine was doing ok. I could burn data and audio cds.

Then my hard drive crashed, and I had to reinstall. My current setup also has added a DVD burner on top of my CD burner.
In both cases, the distribution is the same: Redhat 9.

I can burn audio CDs just fine: I use the -audio switch and point it at the list of .wav files.
But... when I want to burn data CDs, it never seems to generate anything mountable.
For instance, I have two ISOs I'd like to get onto disk, both bootable images (note: I haven't tried with a non-bootable image yet)-
A system recovery CD from Linux Format, and the INSERT bootable security disk.

Both are correctly mounted in loopback mode.

If I use cdrecord, everything looks like it works ok, but then it just doesn't mount. I've tried it with both drives, and gotten the same thing in both cases.

It is possible that there was some magic option that I used to use in my old burncd script (lost in the crash) and have since forgot, but looking through the info page didn't jog my memory.


Any help would be appreciated, but I suspect everyone hates CD questions.


Here's the output if I burn to the lower drive (my older CD burner, which I have seen produce good data CDs, though this is the first time I've tried with a bootable image):

[apologies if it's not normal to post ridiculously huge amounts of terminal text]

[root@violet dl]# cdrecord dev=2,1,0 -speed=6 -v *iso
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright © 1995-2002 J?rg Schilling
TOC Type: 1 = CD-ROM
scsidev: '2,1,0'
scsibus: 2 target: 1 lun: 0
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c 1.75 02/10/21 Copyright 1997 J. Schilling').
atapi: 1
Device type : Removable CD-ROM
Version : 0
Response Format: 1
Vendor_info : 'SAMSUNG '
Identifikation : 'CDRW/DVD SM-348B'
Revision : 'T501'
Device seems to be: Generic mmc2 DVD-ROM.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1959936 = 1914 KB
FIFO size : 4194304 = 4096 KB
Track 01: data 48 MB
Total size: 56 MB (05:33.89) = 25042 sectors
Lout start: 56 MB (05:35/67) = 25042 sectors
Current Secsize: 2048
ATIP info from disk:
Indicated writing power: 4
Is not unrestricted
Is not erasable
Disk sub type: Medium Type A, low Beta category (A-) (2)
ATIP start of lead in: -12508 (97:15/17)
ATIP start of lead out: 359845 (79:59/70)
Disk type: Short strategy type (Phthalocyanine or similar)
Manuf. index: 22
Manufacturer: Ritek Co.
Blocks total: 359845 Blocks current: 359845 Blocks remaining: 334803
Starting to write CD/DVD at speed 8 in real TAO mode for single session.
Last chance to quit, starting real write 0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is OFF.
Performing OPC...
Starting new track at sector: 0
Track 01: 48 of 48 MB written (fifo 100%) [buf 100%] 8.4x.
Track 01: Total bytes read/written: 51281920/51281920 (25040 sectors).
Writing time: 46.789s
Average write speed 7.6x.
Min drive buffer fill was 95%
Fixating...
Fixating time: 35.192s
cdrecord: fifo had 808 puts and 808 gets.
cdrecord: fifo was 0 times empty and 713 times full, min fill was 81%.
[root@violet dl]# mount /dev/scd1 /mnt/cdrom1
/dev/scd1: Invalid argument
mount: block device /dev/scd1 is write-protected, mounting read-only
/dev/scd1: Invalid argument
mount: you must specify the filesystem type


(the mount command will, of course, work fine if I put a working data CD in the drive)



Any suggestions?
Go to the top of the page
 
+Quote Post
jeff_brown
post Apr 12 2004, 12:00 PM
Post #2


Grub-er
**

Group: Members
Posts: 48
Joined: 12-February 04
Member No.: 2,361



For what it's worth:

I had to solve a similar problem: I burned CDs in Linux and read them in Windows, but Windows would not recognize the disc unless I had burned it using the "-joliet-long" option, which renders a Joliet filesystem on the front of the disc, in addition to the normal Linux-style filesystem (the name of which I forget; let's call it Bob).

My version of cdrecord burns a Bob filesystem by default, but maybe it's possible that yours doesn't. If so, it would seem likely that unless you use the extension to include a Bob filesystem, the disc would be unmountable.

But there's a good chance I'm barking up the wrong tree -- especially if you're burning bootable discs, which I don't even know if they come with a filesystem.

More generally, as a computer science person, I would recommend that you break the task into smaller steps -- first see if you can record a data CD. If so, you've isolated the problem; if not, you know exactly how discouraged to be.
Go to the top of the page
 
+Quote Post
cfalcon
post Apr 12 2004, 12:33 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 5-September 03
Member No.: 1,384



You are right, when I am back home I will try to burn a plain data CD and see if it can mount that.
I will be a lot less unhappy in the case where I can burn data CDs, just not *bootable* data CDs.

Still, kinda worried.

The bootable CD ISOs, however, should be the CD image in iso9660 format: they do have a normal filesystem on them, and if I was in the previous directory I could type:

mount -o loop *iso /mnt/cdrom
(I forget the .iso name, but it was the only one in the directory)

Then, if I typed mount, it would list the mounted filesystem with iso9660 (which is the same for plain jane data CDs). Additionally, I could access all the files on it per normal.

Hrmm...
Go to the top of the page
 
+Quote Post
cfalcon
post Apr 13 2004, 01:11 AM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 5-September 03
Member No.: 1,384



No go sad.gif

I can type, as root, from / :
mkisofs -r -o addon.iso addon/

(/addon is the directory I put all the Linux programs that I download: after losing everything once, I figure I should be a little more diligent than last time, as I've had to go and hunt down a bunch of programs)

This makes /addon.iso, which is mountable.

But then if I:
cdrecord dev=2,0,0 -v -speed=8 addon.iso

It burns it and the resulting cd is unmountable.
(at least not with mount /dev/scd0 /mnt/cdrom , my normal command)

Anyone have any ideas? This is a very not-cool situation, but at least it isn't time critical. Without the ability to make backups effectively, however, I'm basically dead in the water- too scared to upgrade wantonly (something will break it eventually).


I didn't try with the Joilet option: everything I've read says that not only does Linux not care about that, it's happy to mount cds with entirely different filesystems on them (though I'm not about to play that game). If you think it's worth another coaster, though, I'll give it a shot.
Go to the top of the page
 
+Quote Post
cfalcon
post Apr 13 2004, 01:14 AM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 5-September 03
Member No.: 1,384



Hmm...

I was just thinking...

If I:
-Put one of the bogus disks into the drive and made an ISO out of it.
-Compared that to the real ISO.

On a real disk, those two should be identical, right? So in this case, is there maybe some information to be had if the two are different?
Go to the top of the page
 
+Quote Post
jeff_brown
post Apr 14 2004, 12:49 AM
Post #6


Grub-er
**

Group: Members
Posts: 48
Joined: 12-February 04
Member No.: 2,361



Hello Mr. Falcon. I don't think I can help. [Anyone else reading this ...?]

I can, however, offer more standard hacker's advice. In C, if something really breaks, and it's little, you can just rewrite it. The same might work here -- if you find two separate lists of instructions for how to burn a CD, and the instruction sets differ, there's a chance one will work even though others don't.

I didn't understand your idea about comparing bogus images to real ones. How would you make an ISO out of a disc you can't mount?

Last -- if you're as cheap as me*, you should get a CD-RW, erasing it from another system after every failure. Then you could try the Joliet thing, and see if Windows reads it. If not, you know the CD itself is bad, rather than Linux's understanding of the CD.

("worth another coaster" -- that was pretty funny)
Go to the top of the page
 
+Quote Post
hughesjr
post Apr 14 2004, 06:56 AM
Post #7


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



can you read the CD in any other machines ... maybe on a windows machine?

It should work, I think.

I had 6 pictures and an mpeg file of my daughter's ballet performance (from my camcorder) in a directory ... I made an ISO by going to that directory and doing this:

mkisofs -r -o new.iso *

then I burned it to CD with this command:

cdrecord driveropts=burnfree dev=ATAPI:0,0,0 new.iso

everything worked fine.....both on windows and linux.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 10:06 PM