Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Help With Screen Resolution, Help with screen resolution
AllGood
post Apr 7 2004, 12:25 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 7-April 04
Member No.: 2,729



I'm a newbie so please forgive me if this is stupid
I ahs changed the screen resolution and when it rebooted the screen didn't fit on the monitor and everything was blurry and doubled up like one box would be open then it would be to the lower right about 2 inches but the cursor wasn't lining up. I tried to use hotkey and cursors to change the the resloution to what i thought it was prior. I rebooted and now it only boots to a text mode. At this point I need to know, or what i think i need to know is, how to change the screen resolution for KDE in a text mode and then get back to KDE.

THX
Go to the top of the page
 
+Quote Post
AllGood
post Apr 7 2004, 12:27 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 7-April 04
Member No.: 2,729



Sorry using Mandrake 10.0
Go to the top of the page
 
+Quote Post
Jim
post Apr 7 2004, 12:44 PM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



Here are a couple things you can try. The first is really simple. Reboot, and when lilo comes up press esc. This brings you to a command line. Type in the name of the system you want to boot and follow it with the command screen=1024x768 or what ever you want your screen resolution to be. So the command would look like this.
Boot: Mandrake_10 screen=1024x768

Replacing Mandrake_10 with the name of your linux system and the resolution with the numbers you want. I would recommend trying either 1024x768 or 800x600 unless you have a wide screen monitor, in which case you need to know your own default.

If this is a flat panel you should know that DPFs don't work well at anything other than their native resolutions. So I would strongly recommend that.

Ounce your into KDE you can go through and change your default screen size back the same way you changed it up.

If that doesn't work, and you are still at the command line. You are going to need to edit your XF86Config file. I am not at a linux machine right now, so I can't look up the syntax but this should help.

Log in as root, or log in as yourself and su, either way you need root privileges. cd to /etc/X11 using the command cd /etc/X11 now do a ls to see the files there. If you have a XF86Config-4 you are going to need to edit that, if not, you will need to edit XF86Config. First create a back up of the file. Run
cp XF86Config-4 XF86Config-4.old
To back it up (drop the Ė4 if its not there)
Now, open your favorite editor like emacs or vi, I recommend emacs if you donít know either. Run the command
emacs XF86Config-4
Now move down towards the bottom. You will be able to see the configuration sections for your video card and your display. Change the screen size to what you want and save it. If its not obvious to you what settings to change, donít worry about it, I will get a follow up post up ounce I get back to my dorm room. If you think you have it. Save it
(F10, f, s) and exit (ctr-x-c).

Ounce your are back out at the command line. Type startx if you made the right changes, it should start up, if not. Head back in. If you donít get it and want to quit. Do this command to restore your old config file.

cp XF86Config-4.old XF86Config-4

And say yes to overwriting. Than come back and see if I have another answer for you.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 12:12 PM