Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Fun With Paths!, No bin containg gtk?
jeff_brown
post Mar 31 2004, 02:12 PM
Post #1


Grub-er
**

Group: Members
Posts: 48
Joined: 12-February 04
Member No.: 2,361



I run all kinds of wonderful software with Gtk or G or Gnome in the title. I've had RPMs called gtkxxxx, libgtkxxxx, and many variants thereof, all installed since last fall. Yet my recent attempts at installing yarec are making me wonder whether I really have Gtk installed. It's creepy.

As has happened before, I found RPM packages for yarec but was unable to download them, so I did it the old fashioned way (./configure, make, make install). I got this warning at ./configure:

checking for GTK - version >= 1.0.1... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: warning: Test for GTK failed.

That's the only complaint it ever gave me.

After installing, calling yarec (with or without arguments) from the command line yields no effect. I thought maybe it was failing to create a window, and if I find Gtk it would work. This hunch led to the following discoveries:

Searching for *bin*gtk* yields nothing, as does evaluating GTK_CONFIG or searching for *gtk-config*. I have all kinds of stuff for gtk, perhaps most notably in /etc/gtk/ and /usr/lib/gtk/. But neither of those directories is a bin, therefore the executable for GTK must be somewhere else, correct?

Once, somewhere, somebody with this problem had to add /opt/gnome/bin to their path. I have no such directory. Is this a succession of unrelated setbacks, or is there some theme here?


Eagerly,
Jeff Brown
Go to the top of the page
 
+Quote Post
Hemant
post Mar 31 2004, 10:50 PM
Post #2


RMS is my Hero
******

Group: Support Specialist
Posts: 782
Joined: 6-October 02
From: Trichy,INDIA
Member No.: 29



Well..it seems that the error is more related to gtk version incompatiblity rather that gtk is not installed or something....

Anyway i have just successfully tried to download yarec from http://rpmfind.net
just search for yarec and in the search result...try all the links mentioned there...


--------------------
Hemant Kumar
user posted image
hemant@linuxhelp.net
Go to the top of the page
 
+Quote Post
hughesjr
post Apr 1 2004, 06:54 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Jeff

yarec is very old (hasn't been updated since Oct. 30th, 2001)... use Audacity instead.

You should be able to install audacity (in mandrake 9.2) with the command:

urpmi audacity

(if you have a contrib or Disk_2 in your urpmi sources).


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 09:47 PM