Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
2 Pages V   1 2 >  
Reply to this topicStart new topic
> Mail Server
Termina
post Mar 29 2004, 01:33 PM
Post #1


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



How would one go about hosting a mail server?

Hopefully includes a web interface login (nifty!)

I've tried sendmail, and that doesn't seem to work for me. =/


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
Termina
post Mar 31 2004, 02:50 PM
Post #2


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



Sorry, bumping


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
chrisw
post Mar 31 2004, 02:54 PM
Post #3


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



why doesnt sendmail work for you?

im am in the process of completing my linux server configurations

and included is configuring sendmail with imap + spam + virus protection....

and i will also be having webmail also....

so any problems with sendmail..i should be able to help


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
Termina
post Mar 31 2004, 03:07 PM
Post #4


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



There doesn't seem to be any errors, but when I try to send to, say "termina@wi.rr.com" (my email addy), I never recieve the email.


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
chrisw
post Mar 31 2004, 03:23 PM
Post #5


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



are you sending from the same computer that your mail server is running?


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
Termina
post Mar 31 2004, 03:25 PM
Post #6


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



Oh, yea. smile.gif Well, sendmail atleast.

I SSH in, then send an email with sendmail (forget the extact way to send atm, sorry XD) to my email addy, but it never shows. =/


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
chrisw
post Mar 31 2004, 03:31 PM
Post #7


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



ok....you ssh into your linux server running sendmail...correct?

then you try to send mail but you never get it...

do you use the mail command to send mail

can you post the contents of your /var/log/maillog file...

is there a firewall blocking port 25?

what kinda email address do you have...is it from your isp?

paste your sendmail.mc file if you dont have that post your sendmail.cf file


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
Robert83
post Mar 31 2004, 03:53 PM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

well I haven't started my first e-mail server [scared from it, don't know why], and I'm still in a dilema on what to choose, postfix or sendmail...but If you could help me with sendmail + antivirus + spam + some webmail I would choose sendmail ... could you help me [In about 1-2 weeks I'm getting the mail computer].

I would need some sorta draft[?hope this is how it's said] step-by-step guide on this, at least till I get one client up and running, the rest will be no problem[I hope].

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
chrisw
post Mar 31 2004, 04:13 PM
Post #9


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



i started to write one but then it got pushed to the side....when i start the configuration of my mail server ill document what i do (hopefully you will be able to follow it) and that you will have a up and running mail server....i feel very confident that my setup is good..because i have had it check by online relay checkers and have passed everyone of them.....ill let you know when i am finished with it....by the way i will be doing my configuration running whitebox linux 3.0a which is essentially RHEL3.0


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
Robert83
post Mar 31 2004, 04:59 PM
Post #10


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

I to was planing on doing it on WhiteBox 3.0 , I think it rocks! smile.gif [I moved most of my servers to whitebox linux]...so I think if you'll do that it'll work for me to. Thanks smile.gif It will really-really help me get things starting.


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Termina
post Apr 1 2004, 06:13 PM
Post #11


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



http://parasite.ath.cx/downloads/mail.log
http://parasite.ath.cx/downloads/sendmail.cf

mail.log seems to be pretty big, sorry. Big as in 41megs. ;-_-

So here's a tailed version of it. biggrin.gif http://parasite.ath.cx/downloads/tailedmail.txt

Once again, I rock! happy.gif


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
chrisw
post Apr 1 2004, 09:48 PM
Post #12


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



ok first of all do you have a domain name?
second..what is the contents of your /etc/hosts file?
third, what is the contents of your:
local-host-names?

i had this problem before on a server and the /etc/hosts
file was wrong....so if you could post it here i could look at it...cause everything else seems ok...thats until i see your /etc/hosts file...then i could definitely determine what is wrong...cause in your log file for some reason it can determine the qualified name...so that looks to me to be a /etc/hosts file problem


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
Termina
post Apr 2 2004, 12:45 PM
Post #13


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



I have a free domain name from DynDNS (parasite.ath.cx)

http://parasite.ath.cx/downloads/hosts

root@box:~# cat /etc/mail/local-host-names
localhost


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
chrisw
post Apr 2 2004, 01:44 PM
Post #14


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



put the name "box" in your local-host-names file
or put the free domain name you got in there,
restart sendmail and try sending mail

if that doesnt work try placing the name of your free domain
in /etc/hosts file

and replace box with it and restart sendmail and try to send mail.....


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
Robert83
post Apr 2 2004, 01:45 PM
Post #15


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

FIRST! : I aplogize for dropping in smile.gif

I just wanted to ask you chrisw , how are you proceeding with you WhiteBox mail server?

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
chrisw
post Apr 2 2004, 03:17 PM
Post #16


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



im am going to try and get to it tonight....shouldnt take to long...just to document how to configure sendmail+imap...i havent figured out a good antivirus app to use...i was using f-prot but i dont like how it is not quite kept up to date with virii defs...

so what ill do is this....
document how to configure sendmail+imap ( just personal preference on using imap)
in the documentation will include how to do smtp-before-auth
and connect to imapS server...

yes i am security concious and connect to my mail server via ssl

later when i get that done..ill let you know...then ill work on
documentation for configuring mailscanner+virus protection part of the setup....

if thats ok with you....
i just dont want to make the documentation too much at once...once i do that ill let you know...


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
Robert83
post Apr 2 2004, 04:18 PM
Post #17


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

Thanks chrisw, and sorry for dropping in smile.gif


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
chrisw
post Apr 2 2004, 04:52 PM
Post #18


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



its ok....


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
Robert83
post Apr 2 2004, 04:53 PM
Post #19


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

I was wondering, why can't I post polls?


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
chrisw
post Apr 2 2004, 05:25 PM
Post #20


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



dont know let me check...

ok,
you have to be a moderator or admin to start polls...


--------------------

Chris W.
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 12th December 2017 - 04:44 PM