Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Ip Aliasing (lo:* To Eth0:*)
Eric
post Mar 27 2004, 02:59 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 27-March 04
Member No.: 2,661



currently have 9 Internet IP addresses on lo:* (excluding 127.0.0.1)
How do I change them to eth0:* instead?
Do I need to do anything with route or ifconfig afterwards?


Thanks
Eric
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 27 2004, 06:42 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



What is your distro?


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Eric
post Mar 27 2004, 12:55 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 27-March 04
Member No.: 2,661



RH9.0
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 27 2004, 03:24 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



You should have (in the directory /etc/sysconfig/network-scripts/) several files named:

ifcfg-lo:1
ifcfg-lo:2


If you want to keep the same IPs on them that they have now, just rename them to:

ifcfg-eth0:1
ifcfg-eth0:2


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Eric
post Mar 27 2004, 05:37 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 27-March 04
Member No.: 2,661



After renaming them, I can't access the server anymore (it's a remote machine)... sad.gif
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 28 2004, 05:32 AM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



I didn't know it was a remote server ....

There might be a problem with iptables .... is it a NAT or FIREWALL server. If not, you might be able to get someone to turn off iptables and get in ...

After you get in post the results of ifconfig and iptables. If you don't want to post the full IP addresses, just post enough so we can see about fixing the problem:

for example:

24.122.34.34
24.122.34.35
24.122.34.36

could be:

x.x.x.34
x.x.x.35
x.x.x.36


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Eric
post Mar 28 2004, 04:05 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 27-March 04
Member No.: 2,661



All iptables policies were removed before I did all this.
Problem has been solved, I manually edited the files in /etc/sysconfig/network-scripts/


Thanks.
Eric
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th December 2017 - 12:05 PM