Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Vsftpd, Having problrems loging in.
kingpin
post Mar 22 2004, 05:54 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 22-March 04
Member No.: 2,634



How can I setup a user in Vsftpd, I just rented a dedicated server with RedHat 9, with Webmin installed and When I try to login I get the message :
CODE
500 OOPS: vsftpd: cannot locate user specified in 'ftp_username'


Any Help is appreciated. I looked thru So many tutorials and being the "uber Noob" smile.gif that I am I didnt figure it out. again I would appreciate any replies.

This post has been edited by kingpin: Mar 22 2004, 05:54 PM
Go to the top of the page
 
+Quote Post
Robert83
post Mar 22 2004, 06:02 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

just installed vsftpd to see how it looks like...

I've just finished reading /etc/vsftpd/vsftpd.conf

have a look in that file [it has lot of info] on what things do.


and also check /etc/vsftpd.ftpusers that you're client is listed
and /etc/vsftpd.userlist


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 22 2004, 06:03 PM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



I think the problem is that

webmin is not listed in the user allow list /etc/ in either of those vsftpd user list ...etc files...


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 22 2004, 06:08 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



just checked

again

I think you'll need to remove if webmin is present in either of those files, since those are the users that are not allowed


you should do the following


/etc/vsftpd/vsftpd.conf

search for this line

user_list deny Yes

if you find it comment it out like this

#user_list deny Yes

then add the following line

user_list enable yes


Sincerely
Robert B


ps.: this might be unsafe...


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 22 2004, 06:09 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



also please
have a look at these


in a terminal type :

man vsftpd

[you can use the up and down arrow to scroll up / down and press CTRL-Z to exit]

also see

man vsftpd.conf [for detailed configuration options, with good explanation ]

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
kingpin
post Mar 22 2004, 06:44 PM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 22-March 04
Member No.: 2,634



Wow thanx for all the replies so quickly. I will go try this right now.
Go to the top of the page
 
+Quote Post
kingpin
post Mar 22 2004, 06:57 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 22-March 04
Member No.: 2,634



Im sorry but I tried to use SSH to login and here is what I got fromwebmin :
CODE
Failed to lookup IP address for linux to test telnet or SSH server.

I also tried using putty to login and it asked my my username I put it in then it asked my password I put that it and then It just shutoff, I tried this multiple time with same results. I been searching around on the net but the putty site or other sites I went to had no info on this behavior.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 04:20 AM