Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
2 Pages V   1 2 >  
Reply to this topicStart new topic
> Fedora Core 1 Nvidia Drivers
Robert83
post Mar 18 2004, 04:32 AM
Post #1


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi I get this error when trying to install the nvidia audio driver :

[root@demon nvaudio]# make
make nvaudio.o
make[1]: Entering directory `/home/NForce 2/nforce/nvaudio'
cc -D__KERNEL__ -I/lib/modules/2.4.22-1.2115.nptl/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DREMAP_NEW -c -o nvhw.o nvhw.c
nvhw.c:14:25: asm/uaccess.h: No such file or directory
In file included from /usr/include/linux/sched.h:14,
from nvhw.h:15,
from nvhw.c:16:
/usr/include/linux/timex.h:56: error: syntax error before "and"
In file included from /usr/include/linux/timex.h:126,
from /usr/include/linux/sched.h:14,
from nvhw.h:15,
from nvhw.c:16:
/usr/include/asm/timex.h:33: error: syntax error before "cacheflush_time"
/usr/include/asm/timex.h:35: error: syntax error before "get_cycles"
In file included from /usr/include/linux/sched.h:14,
from nvhw.h:15,
from nvhw.c:16:
/usr/include/linux/timex.h:147: error: field `time' has incomplete type
In file included from /usr/include/linux/bitops.h:69,
from /usr/include/asm/system.h:7,
from /usr/include/linux/sched.h:16,
from nvhw.h:15,
from nvhw.c:16:
/usr/include/asm/bitops.h:327:2: warning: #warning This includefile is not available on all architectures.
/usr/include/asm/bitops.h:328:2: warning: #warning Using kernel headers in userspace: atomicity not guaranteed
In file included from /usr/include/linux/signal.h:4,
from /usr/include/linux/sched.h:25,
from nvhw.h:15,
from nvhw.c:16:
/usr/include/asm/signal.h:107: error: syntax error before "sigset_t"
/usr/include/asm/signal.h:110: error: syntax error before '}' token
In file included from /usr/include/linux/sched.h:81,
from nvhw.h:15,
from nvhw.c:16:
/usr/include/linux/timer.h:45: error: syntax error before "spinlock_t"
/usr/include/linux/timer.h:53: error: syntax error before '}' token
/usr/include/linux/timer.h:67: error: syntax error before "tvec_base_t"
/usr/include/linux/timer.h:101: error: syntax error before "tvec_bases"
/usr/include/linux/timer.h: In function `init_timer':
/usr/include/linux/timer.h:105: error: dereferencing pointer to incomplete type
/usr/include/linux/timer.h:105: error: dereferencing pointer to incomplete type
/usr/include/linux/timer.h:106: error: dereferencing pointer to incomplete type
/usr/include/linux/timer.h: In function `timer_pending':
/usr/include/linux/timer.h:121: error: dereferencing pointer to incomplete type
In file included from nvhw.h:16,
from nvhw.c:16:
/usr/include/linux/delay.h:13:23: asm/delay.h: No such file or directory
In file included from nvhw.h:22,
from nvhw.c:16:
/usr/include/asm/io.h:4:2: warning: #warning <asm/io.h> is deprecated, use <sys/io.h> instead
In file included from nvhw.h:23,
from nvhw.c:16:
/usr/include/asm/dma.h: At top level:
/usr/include/asm/dma.h:138: error: syntax error before "dma_spin_lock"
In file included from nvhw.h:23,
from nvhw.c:16:
/usr/include/asm/dma.h:298:2: warning: #warning Using kernel headers in userspace!
In file included from nvhw.c:16:
nvhw.h:28:30: linux/ac97_codec.h: No such file or directory
nvhw.h:30:25: asm/uaccess.h: No such file or directory
nvhw.h:31:25: asm/hardirq.h: No such file or directory
In file included from nvhw.h:33,
from nvhw.c:16:
chaninfo.h:103: error: syntax error before "wait_queue_head_t"
chaninfo.h:103: warning: no semicolon at end of struct or union
chaninfo.h:120: error: syntax error before '}' token
chaninfo.h:120: warning: type defaults to `int' in declaration of `dmabuf'
chaninfo.h:120: warning: data definition has no type or storage class
chaninfo.h:129: error: field `open_sem' has incomplete type
chaninfo.h:130: error: syntax error before "wait_queue_head_t"
chaninfo.h:130: warning: no semicolon at end of struct or union
chaninfo.h:148: error: syntax error before ':' token
chaninfo.h:149: error: syntax error before ':' token
chaninfo.h:150: error: syntax error before ':' token
chaninfo.h:153: error: syntax error before "lock"
chaninfo.h:153: warning: type defaults to `int' in declaration of `lock'
chaninfo.h:153: warning: data definition has no type or storage class
In file included from nvhw.c:16:
nvhw.h:99: error: syntax error before "spinlock_t"
nvhw.h:99: warning: no semicolon at end of struct or union
nvhw.h:148: error: syntax error before '}' token
nvhw.c: In function `alloc_dmabuf':
nvhw.c:38: error: dereferencing pointer to incomplete type
nvhw.c:41: error: dereferencing pointer to incomplete type
nvhw.c:42: error: dereferencing pointer to incomplete type
nvhw.c:44: error: dereferencing pointer to incomplete type
nvhw.c:45: error: dereferencing pointer to incomplete type
nvhw.c:45: error: dereferencing pointer to incomplete type
nvhw.c:47: error: dereferencing pointer to incomplete type
nvhw.c:47: error: dereferencing pointer to incomplete type
nvhw.c:49: error: dereferencing pointer to incomplete type
nvhw.c:49: error: dereferencing pointer to incomplete type
nvhw.c:59: warning: implicit declaration of function `pci_alloc_consistent'
nvhw.c:59: error: dereferencing pointer to incomplete type
nvhw.c:61: error: dereferencing pointer to incomplete type
nvhw.c:61: warning: assignment makes pointer from integer without a cast
nvhw.c:67: error: `ENOMEM' undeclared (first use in this function)
nvhw.c:67: error: (Each undeclared identifier is reported only once
nvhw.c:67: error: for each function it appears in.)
nvhw.c:75: error: dereferencing pointer to incomplete type
nvhw.c:75: error: dereferencing pointer to incomplete type
nvhw.c:76: error: dereferencing pointer to incomplete type
nvhw.c:77: error: dereferencing pointer to incomplete type
nvhw.c:81: warning: implicit declaration of function `virt_to_page'
nvhw.c:81: warning: assignment makes pointer from integer without a cast
nvhw.c:82: warning: assignment makes pointer from integer without a cast
nvhw.c:82: error: increment of pointer to unknown structure
nvhw.c:82: error: arithmetic on pointer to an incomplete type
nvhw.c:83: error: `PG_reserved' undeclared (first use in this function)
nvhw.c:83: error: dereferencing pointer to incomplete type
nvhw.c: In function `dealloc_dmabuf':
nvhw.c:93: error: dereferencing pointer to incomplete type
nvhw.c:95: error: dereferencing pointer to incomplete type
nvhw.c:98: error: dereferencing pointer to incomplete type
nvhw.c:98: error: dereferencing pointer to incomplete type
nvhw.c:98: warning: assignment makes pointer from integer without a cast
nvhw.c:99: error: dereferencing pointer to incomplete type
nvhw.c:99: warning: assignment makes pointer from integer without a cast
nvhw.c:99: error: increment of pointer to unknown structure
nvhw.c:99: error: arithmetic on pointer to an incomplete type
nvhw.c:100: error: `PG_reserved' undeclared (first use in this function)
nvhw.c:100: error: dereferencing pointer to incomplete type
nvhw.c:102: warning: implicit declaration of function `pci_free_consistent'
nvhw.c:102: error: dereferencing pointer to incomplete type
nvhw.c:102: error: dereferencing pointer to incomplete type
nvhw.c:103: error: dereferencing pointer to incomplete type
nvhw.c:103: error: dereferencing pointer to incomplete type
nvhw.c:110: error: dereferencing pointer to incomplete type
nvhw.c:111: error: dereferencing pointer to incomplete type
nvhw.c:111: error: dereferencing pointer to incomplete type
nvhw.c: In function `prog_dmabuf':
nvhw.c:122: error: dereferencing pointer to incomplete type
nvhw.c:124: error: dereferencing pointer to incomplete type
nvhw.c:126: error: dereferencing pointer to incomplete type
nvhw.c:130: error: dereferencing pointer to incomplete type
nvhw.c:134: error: dereferencing pointer to incomplete type
nvhw.c:138: error: dereferencing pointer to incomplete type
nvhw.c:139: error: dereferencing pointer to incomplete type
nvhw.c:139: error: dereferencing pointer to incomplete type
nvhw.c:140: error: dereferencing pointer to incomplete type
nvhw.c:140: error: dereferencing pointer to incomplete type
nvhw.c:141: error: dereferencing pointer to incomplete type
nvhw.c:150: error: dereferencing pointer to incomplete type
nvhw.c:150: error: dereferencing pointer to incomplete type
nvhw.c:151: error: dereferencing pointer to incomplete type
nvhw.c:152: error: dereferencing pointer to incomplete type
nvhw.c:152: error: dereferencing pointer to incomplete type
nvhw.c:152: error: dereferencing pointer to incomplete type
nvhw.c:153: error: dereferencing pointer to incomplete type
nvhw.c:153: error: dereferencing pointer to incomplete type
nvhw.c:154: error: dereferencing pointer to incomplete type
nvhw.c:154: error: dereferencing pointer to incomplete type
nvhw.c:155: error: dereferencing pointer to incomplete type
nvhw.c:155: error: dereferencing pointer to incomplete type
nvhw.c:155: error: dereferencing pointer to incomplete type
nvhw.c:157: warning: implicit declaration of function `memset'
nvhw.c:157: error: dereferencing pointer to incomplete type
nvhw.c:157: error: dereferencing pointer to incomplete type
nvhw.c:159: error: dereferencing pointer to incomplete type
nvhw.c:161: error: dereferencing pointer to incomplete type
nvhw.c:162: error: dereferencing pointer to incomplete type
nvhw.c:164: error: dereferencing pointer to incomplete type
nvhw.c:165: error: dereferencing pointer to incomplete type
nvhw.c:167: error: dereferencing pointer to incomplete type
nvhw.c:170: error: dereferencing pointer to incomplete type
nvhw.c:177: error: dereferencing pointer to incomplete type
nvhw.c:194: error: dereferencing pointer to incomplete type
nvhw.c:196: error: dereferencing pointer to incomplete type
nvhw.c:198: error: dereferencing pointer to incomplete type
nvhw.c:200: error: dereferencing pointer to incomplete type
nvhw.c:200: error: dereferencing pointer to incomplete type
nvhw.c:203: error: dereferencing pointer to incomplete type
nvhw.c:216: error: dereferencing pointer to incomplete type
nvhw.c:219: error: dereferencing pointer to incomplete type
nvhw.c:221: error: dereferencing pointer to incomplete type
nvhw.c:224: error: dereferencing pointer to incomplete type
nvhw.c: In function `Nvaudio_ac97_get':
nvhw.c:242: error: dereferencing pointer to incomplete type
nvhw.c:244: error: dereferencing pointer to incomplete type
nvhw.c:246: error: dereferencing pointer to incomplete type
nvhw.c:247: warning: implicit declaration of function `udelay'
nvhw.c:249: error: dereferencing pointer to incomplete type
nvhw.c: In function `Nvaudio_ac97_set':
nvhw.c:254: error: dereferencing pointer to incomplete type
nvhw.c:256: error: dereferencing pointer to incomplete type
nvhw.c:258: error: dereferencing pointer to incomplete type
nvhw.c:260: error: dereferencing pointer to incomplete type
nvhw.c: In function `Nvaudio_Recalfreespace':
nvhw.c:268: error: dereferencing pointer to incomplete type
nvhw.c:270: error: dereferencing pointer to incomplete type
nvhw.c:283: error: dereferencing pointer to incomplete type
nvhw.c:296: error: dereferencing pointer to incomplete type
nvhw.c:305: error: dereferencing pointer to incomplete type
nvhw.c:306: error: dereferencing pointer to incomplete type
nvhw.c:313: error: dereferencing pointer to incomplete type
nvhw.c:314: error: dereferencing pointer to incomplete type
nvhw.c: In function `Nvaudio_MultiChannel_volume':
nvhw.c:328: error: dereferencing pointer to incomplete type
nvhw.c:331: error: dereferencing pointer to incomplete type
nvhw.c:336: error: dereferencing pointer to incomplete type
nvhw.c:339: error: `AC97_MASTER_VOL_STEREO' undeclared (first use in this function)
nvhw.c:344: error: `AC97_SURROUND_MASTER' undeclared (first use in this function)
nvhw.c:355: error: `AC97_PCMOUT_VOL' undeclared (first use in this function)
nvhw.c:359: error: `AC97_CENTER_LFE_MASTER' undeclared (first use in this function)
nvhw.c: In function `Nvaudio_SetSpkrRegister':
nvhw.c:374: error: dereferencing pointer to incomplete type
nvhw.c:376: error: dereferencing pointer to incomplete type
nvhw.c:379: error: dereferencing pointer to incomplete type
nvhw.c:383: error: dereferencing pointer to incomplete type
nvhw.c:387: error: dereferencing pointer to incomplete type
nvhw.c:395: error: dereferencing pointer to incomplete type
nvhw.c:395: error: dereferencing pointer to incomplete type
nvhw.c:395: error: dereferencing pointer to incomplete type
nvhw.c:398: error: dereferencing pointer to incomplete type
nvhw.c: At top level:
chaninfo.h:151: error: storage size of `dmabuffer' isn't known
make[1]: *** [nvhw.o] Error 1
make[1]: Leaving directory `/home/NForce 2/nforce/nvaudio'
make: *** [all] Error 2
[root@demon nvaudio]#

what to do? , I have no sound yet...did all the updates, kernel was also updated...

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 18 2004, 05:18 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Shouldn't have to do the nvidia should driver ... it should work without it .... let me look around.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 18 2004, 05:45 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



OK,

I built the RPM for 2174 kernel .... you can download it here



Install with:

rpm -Uvh NVIDIA_nforce-1.0-0261.athlon.rpm


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 18 2004, 08:04 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

Thank you, thank you, thank you, thank you, thank you!!!

Currently I cannot access you're website, because my ISP is having problems, but I hope that the rpm you created will stay there for another day... and thank you, thank you again!



Thank you!

Sincerely
Robert B

smile.gif smile.gif smile.gif smile.gif smile.gif smile.gif smile.gif


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 18 2004, 08:08 AM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Strange, I still cannot access you're site, but the rest of the net works fine...


the link is good?

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 18 2004, 08:08 AM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



If you have an FTP server, PM me a password and I'll upload it if you want ...

I'll leave it up forever (although I'll rename it with the kernel version and OS later).


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 18 2004, 08:09 AM
Post #7


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



It works for me .... let me test it from outside...


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 18 2004, 08:12 AM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Ok, thanx

I was succesfull this time...


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 18 2004, 08:15 AM
Post #9


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



By the way,

do I need to change the 810_audio to nvaudio in modprobe.conf or modules.conf ?

[I don't know If this is just me, or I'm doing things bad, but I did it again, I've got one modprobe.conf , and one modules.conf... with almost the same lines, it seems that I need both for the system to function correctly, the sound ethernet is defined in modules.conf]


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 18 2004, 08:20 AM
Post #10


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



I hope, that I need to change something, because I gave the system a restart after the rpm installation and still no sound...

tried modporbe nvaudio but nothings...show error, module not found

modprobe i810_audio loads up without any warning or anything at all , but no sound, the volume is maxed out, and MUTE is not selected.


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 18 2004, 08:22 AM
Post #11


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



should be able to just replace it in modules.conf for the 2.4.x kernels ... modprobe.conf is a 2.6.x kernel replacement for modules.conf.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 18 2004, 08:25 AM
Post #12


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



do:

rpm -ql NVIDIA_nforce-1.0-0261 | grep modules

what is the output?


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 18 2004, 08:28 AM
Post #13


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

I'm sorry for wasting you're time...I've found it, just opened up the rpm with mc [F3], and read the first pages, and saw that it should'v replaced the alias to nvaudio in modules.conf , but it did not do it, so I changed it myself, and guess what? YAHHHHHOOOOOOOOOOOOOOOOOOOOOOOOOOOOO smile.gif [now I only hope I will succed with Ati smile.gif smile.gif ],

So thank you again for the rpm.

Sincerely
Robert B

smile.gif Oh happy day smile.gif lalalalal smile.gif now I can listen to some music again, while doing the ati stuff... smile.gif


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 18 2004, 08:30 AM
Post #14


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Make sure you go through the kernel source setup stuff .... remove the custom, make dep, etc ... but remember ... no make install inside the kernel source directory....(or else you will get a new kernel).


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 18 2004, 08:33 AM
Post #15


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



thanx for remiding me, that make install part I forgot...okay! so I build the ati modules, and from the ati dir I do the make install... or from / that is good no?

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 18 2004, 08:47 AM
Post #16


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



first setup the kernel source:

cd /usr/src/linux-2.4.22-1.2174.nptl/

make mrproper


edit Makefile ... remove custom from the extra version line

cp /boot/config-2.4.22-1.2174.nptl .config

make oldconfig

make dep


you're done in source

Install the ati rpm like this:

rpm -Uvh --force fglrx-4.3.0-3.7.6.i386.rpm

the run fglrxconfig, then reboot and it should work....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 18 2004, 09:17 AM
Post #17


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

it's me again smile.gif

here is the output of the ati driver installation

[root@demon Ati9600Pro Driver]# rpm -Uvh --force fglrx-4.3.0-3.7.6.i386.rpm
Preparing... ########################################### [100%]
1:fglrx ########################################### [100%]
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
probing for VMA API version...
doing script based build for kernel 2.4.x and similar
compiling './agpgart_be.c'...
compiling './agp3.c'...
compiling './i7505-agp.c'...
compiling './nvidia-agp.c'...
compiling './firegl_public.c'...
linking of fglrx kernel module...
duplicating results into driver repository...
done.
==============================
- creating symlink
- recreating module dependency list
depmod: *** Unresolved symbols in /lib/modules/2.4.22-1.2174.nptl/kernel/drivers/net/nvnet.o
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.22-1.2174.nptl/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. © 2002 - ATI Technologies, Starnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module fglrx loaded, with warnings
done.
depmod: *** Unresolved symbols in /lib/modules/2.4.22-1.2174.nptl/kernel/drivers/net/nvnet.o
Installed: qt3 (gcc 3.2) based control panel application
===
ATI display drivers successfully installed
please run 'fglrxconfig' now
===
[root@demon Ati9600Pro Driver]#


so I guess I need to do those first steps right?

and after that run fglrxrconfig...

and one more thing, after all this done make install from somewhere not the kernel source...


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 18 2004, 10:52 AM
Post #18


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

I've did everything you told me, but 3D ACCELERATION is still not available...

and when I try playing movies with mplayer, the following error comes up, and only sound is played :

fbdev: Can't open /dev/fb0: No such device

what is this? how can I fix it? [is this related to the 3D of Ati ? ]


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Termina
post Mar 18 2004, 11:10 AM
Post #19


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



Ah, the joys of ATI. ;-_-


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
Robert83
post Mar 18 2004, 11:42 AM
Post #20


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Yes but I will NOT GIVE UP, muhahhahaha
I might throw the monitor out trough the window, I might use a battleaxe to press buttons on my keyboard...but I will eventualy do this...my guess is, with Fedora Core 2 [once the stable is released], it'll work, was reading a lot, and found something about 2.4.x kernels not detecting or something the AGP3.0....

But somebody here might have some aditional ideas for me? [shall I try Kernel 2.6.x again?]


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 03:15 AM