Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Few Problems With Slackware, Help anyone?
Termina
post Mar 14 2004, 03:00 AM
Post #1


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



On my "main" computer, I decided to try out slackware. To my surprise, I was able to install it on my first try *pumps his fist in the air, and declares himself supreme overlord of earth*

Internet wasn't work at first, but after giving the commands "ifconfig eth0 down,ifconfig eth0 -dynamic up,dhcpcd -B" everything worked fine, even after restart. Yay!

Problems:

1. When I try to use the scrollwheel on my mouse, it just moves the cursor halfway across the screen (in the direction I tried to scroll). How can I fix this?

2. How can I have certain commands start at startup in Slackware or Debian? (/etc/init.d for debian, I know, but WHAT exactly do I put in there? blink.gif )

3. In VI for some reason I cannot use the backspace key (after going into append or insert mode) to delete text. It just moves backwards through the text, changing nothing. This is a tad annoying (I'm used to using backspace, not having to press Esc and using the d-arrow combo).

4. I'm going to attempt to install the Radeon9200 video driver off ATIs website (and pray it doesn't screw up X like it did with debian), but I need the "sh" shell, apparently. Where can I set that? XD


Anyways, thanks for any help you could give me! happy.gif


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 14 2004, 09:02 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Good job biggrin.gif
-----------------------------------------
concerning vi, it is not linked to vim on a slackware install ... it is linked to something called elvis. vim is installed on my slackware install, so I just changed the link so that the command vi points to vim instead of elvis.

If you would rather have the link named vi be vim (like me), rather than elvis, then do this ...

rm /usr/bin/vi

ln -s /usr/bin/vim /usr/bin/vi
---------------------------------------
For the scroll wheel, take a look at the file (with your new vi wink.gif ):

/etc/X11/XF86Config

Find the Section "InputDevice" for your mouse and find the line that says:

Option "Protocol" "whatever_it_is"

and change it to:

Option "Protocol" "ExplorerPS/2"

look for (or add) a line:

Option "ZAxisMapping" "4 5"

remark out (with a #) any other Mapping lines....
------------------------------------------------------
For slackware, you can put the startup stuff in /etc/rc.d/rc.local .... but if you need stuff to startup and shutdown, you should write a startup/shutdown script and put the script in /etc/rc.d ... you would start it inside the script /etc/rc.d/rc.M and stop it inside /etc/rc.d/rc.0.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Termina
post Mar 14 2004, 02:52 PM
Post #3


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



Thanks, the mouse works perfectly now. smile.gif

My only concern is, VI is still a little weird. I cannot move around with the arrow keys in append mode (it just makes capital As, Bs, Cs, and Ds). O_o

Not the biggest deal, just a concern.


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 14 2004, 09:19 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



try typing vim instead of vi ... if it is still wierd ... and the same, then try this as your config file:

/usr/share/vim/vimrc

CODE
" The following are some sensible defaults for Vim for most users.
" We attempt to change as little as possible from Vim's defaults,
" deviating only where it makes sense
set nocompatible        " Use Vim defaults (much better!)
set bs=2                " Allow backspacing over everything in insert mode
set ai                  " Always set auto-indenting on
"set backup             " Keep a backup file
set viminfo='20,"500   " read/write a .viminfo file -- limit regs to 500 lines
set history=50          " keep 50 lines of command history
set ruler               " Show the cursor position all the time

" Added to default to high security within Gentoo. Fixes bug #14088.
" Modified 07 Oct 2003 by agriffis from "modelines=0" to "nomodeline"
" according to conversation on vim devel ML:
" http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=212696
" http://article.gmane.org/gmane.editors.vim.devel/4410
set nomodeline

if v:lang =~ "^ko"
 set fileencodings=euc-kr
 set guifontset=-*-*-medium-r-normal--16-*-*-*-*-*-*-*
elseif v:lang =~ "^ja_JP"
 set fileencodings=euc-jp
 set guifontset=-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*
elseif v:lang =~ "^zh_TW"
 set fileencodings=big5
 set guifontset=-sony-fixed-medium-r-normal--16-150-75-75-c-80-iso8859-1,-taipei-fixed-medium-r-normal--16-150-75-75-c-160-big5-0
elseif v:lang =~ "^zh_CN"
 set fileencodings=gb2312
 set guifontset=*-r-*
endif
if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
 set fileencodings=utf-8,latin1
endif

" Don't use Ex mode, use Q for formatting
map Q gq

" Switch syntax highlighting on, when the terminal has colors
" Also switch on highlighting the last used search pattern.
if &t_Co > 2 || has("gui_running")
 syntax on
 set hlsearch
endif

if &term=="xterm"
 set t_RV=          " don't check terminal version
 set t_Co=8
 set t_Sb=^[4%dm
 set t_Sf=^[3%dm
endif

if has("autocmd")

augroup gentoo
 au!

 " Gentoo-specific settings for ebuilds.  These are the federally-mandated
 " required tab settings.  See the following for more information:
 " http://www.gentoo.org/doc/en/xml/gentoo-howto.xml
 au BufRead,BufNewFile *.e{build,class} let is_bash=1|set ft=sh
 au BufRead,BufNewFile *.e{build,class} set ts=4 sw=4 noexpandtab

 " In text files, limit the width of text to 78 characters, but be careful
 " that we don't override the user's setting.
 autocmd BufNewFile,BufRead *.txt if &tw == 0 | set tw=78 | endif

 " When editing a file, always jump to the last cursor position
 autocmd BufReadPost *
        if line("'"") > 0 && line ("'"") <= line("$") |
          exe "normal g'"" |
        endif
augroup END

endif " has("autocmd")


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 08:04 AM