Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
> Modem Help Please, My modem driving me crazy, help please
post Mar 8 2004, 10:51 PM
Post #1

I Eat C Code for Breakfast

Group: Members
Posts: 210
Joined: 8-March 04
From: Chicago, USA
Member No.: 2,544


I am new to the Linux, just installed Red Hat 9.0 a few days ago. Installation was a breeze, the system was up and running in no time.

But when trying to configure the internet connection, I hit a snag with my modem. Here is what is happening:

I am using KDE, so I went to KPPP to configure my connection. The modem is a US Robotics PCI model 5610, hardware-based (bought specifically for Linux, as winmodem support is spotty I hear). KPPP is pointing to devmodem as default and I left that setting alone. Then I entered the rest of info, following the excelent KPPP tutorial at Having finished and checked the configuration, I hit connect and nothing happened, KPPP just kept displaying "Initializing modem" forever. Hit "Cancel", go back to KPPP setup. This time I clicked on "Query Modem" button and the modem responded to all ATI commands that KPPP sent. So I went to the Terminal part of KPPP and tried a few commands and the modem responded. It even dialed out my ISP's access number and got connected but only from the Terminal, when manually entering commands. So it is not a hardware problem (besides, modem works fine under Windows) but rather software I guess. It is really puzzling, the modem dials out and connects from Terminal, but not when you use KPPP "Connect" button. Am I doomed to manual connections via Terminal commands??? If so I am not familiar with modem commands enough to establish a connection, I can only make it dial from terminal.

I tried GNOME and it's Network Device Control option as well (as described in "Red Hat 9.0 for dummies"). After the setup, it tries to activate the connection, but a message pops up "Unable to activate the connection, Error 8".

US Robotics website has a driver RPM for Red Hat 6.0 and higher, tried it but to no avail.

This is the best I can do to desrcibe the problem. It is really frustrating and puzzling situation, any help will be greatly appreciated.

Greg L.

-- The Pole
Go to the top of the page
+Quote Post
Start new topic
post Mar 11 2004, 03:20 PM
Post #2

Its GNU/

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3

It sounds like your /dev/modem is not pointing to the correct device.

COM1: /dev/ttyS0
COM2: /dev/ttyS1
COM3: /dev/ttyS2
COM4: /dev/ttyS3

These are the 4 communications ports that your modem could possibly be connected through. I don't remember how you can find out quickly which one your modem is connected to, but if all else fails, try each one of them.

To change where your /dev/modem points to, issue the following commands as root:

$ rm /dev/modem
$ ln -s /dev/ttyS0 /dev/modem

then test the connection, if it doesn't work, repeat with ttyS1, etc.

If it doesn't work for all 4 of them, then we have a bigger problem. Do the following:

$ dmesg > dmesg.log

and paste your dmesg.log here so i can have a look at it.

Corey Quilliam
(former) Administrator

Want to help out Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
+Quote Post

Posts in this topic
- lesio1974   Modem Help Please   Mar 8 2004, 10:51 PM
- - Corey   It sounds like your /dev/modem is not pointing to ...   Mar 11 2004, 03:20 PM
- - lesio1974   Hello Sorry, I got frustrated waiting for any rep...   Mar 11 2004, 07:02 PM
- - lesio1974   Hello Just wanted to let you know that I am OK. D...   Mar 12 2004, 03:36 AM
- - Corey   congrats   Mar 12 2004, 11:14 AM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 21st March 2018 - 08:01 AM