Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Setting Up Ssh, from scratch
Jim
post Mar 7 2004, 06:20 PM
Post #1


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



I want to set my computer up so I can SSH into it from home over spring break. I want to be able to run stuff from home and have access to my files. I am familair with ssh-ing into systems and what not, but I have never set up a box to be a host.

So I was looking if anyone know a good step by step page that would get me started at how to set up my box. I tried goolgle and looked at a couple pages but they didn't seem to work.

Any help would be great. Thanks


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 7 2004, 07:15 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



just edit the /etc/ssh/sshd_config file and make sure a couple things are not set at default ... (get rid of the # in front of these and set to these value):

This is what I turn on on my boxes:

Protocol 2
X11Forwarding yes
SyslogFacility AUTHPRIV
Subsystem sftp /usr/libexec/openssh/sftp-server

(your location for sftp-server might be different) ...

make sure to turn off Protocol 1 ... ie don't use Protocol 2,1

------------
execute the following command to start sshd:

/etc/init.d/sshd restart

-----------
If you have iptables running, you will need to open tdp port 22 inbound.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Jim
post Mar 7 2004, 08:54 PM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



I don't have an sshd_config file, I only have an ssh_config file.

There was a host section where I could make the suggested changes so I did (yes i backed up the old file first) but than I wasn't able to run the command

/etc/init.d/sshd restart

What do I need to do?


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 7 2004, 09:17 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



The changes you made to ssh_config were for the client that you connect with ...

sshd is probably not installed ....

I'm booting to my mandrake install right now to see what needs to be installed:

----------------
You need to install the package:

openssh-server


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 14th December 2017 - 10:08 AM