Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Nvidia Driver Problems, Problem after Problem
GwarTime
post Mar 1 2004, 06:40 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 1-March 04
Member No.: 2,504



Im pretty new to linux, I spent all weekend reading how tos to get red hat 9 running to my liking.

One thing I really need help on, is the nvidia drivers for my video card. I already tried running it in init 3 but it says it doesnt recognize my kernel, and wants the kernel developement files(??)

I tried to get it off the redhat cd and it says im missing krb5-libs = 1.2.7-10 and openssl = 0.9.7a-2 I dont have the slightest clue where these are.

Also, I read about the various problems people are having with nvidia drivers and the newer kernel, should I wait it out for new drivers to be released? and are there any alternatives to the nvidia drivers (with 3D acceleration)

System specs
Red Hat 9
20gb Maxtor
Some MSI via chipset MB
Athlon 1.33 ghz
512 mb SDram
Geforce2 MX (Im a student, im poor)
Soundblaster LIVE! 5.1

EDIT: clarity, im tired
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 2 2004, 09:35 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



you need to install the kernel-source package .... then follow the directions on the nvidia site ...


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
mianve
post Mar 11 2004, 09:00 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 22
Joined: 8-March 04
From: Louisiana, U.S.A.
Member No.: 2,540



I had the same problem but got help, this reall works. Just remember "Linux is Case sensitive, I can't stress this enough!!! try this it worked for me on my Mandrake 9.2 system which is Red Hat based.


1. Make sure you have your kernel-source installed:

- open a konsole (ALT-F2 and type 'konsole') then do:

# rpm -qa|grep kernel

If kernel-source is not listed, install it with:

# su (hit enter and type your root password)
# urpmi kernel-source (hit enter and say 'y' to any questions)

2. Download the Linux driver from NVIDIA:
http://download.nvidia.com/XFree86/Linux-x...0-5336-pkg1.run

3. Exit out of X when you done downloading (Right click on the desktop and
select 'logout', and logout of the session).

4. This should bring you back to the login screen. Switch to a console
(press CTRL-ALT-F1) and login with 'root' and your root password.

5. Turn off X by typing:

# init 3

6. Run the NVidia installer, by changing to the directory you downloaded it
to, and doing:

# sh NVIDIA-Linux-x86-1.0-5336-pkg1.run

7. Agree to everything it says, unless you don't want to smile.gif

8. When it is done, edit '/etc/X11/XF86Config-4':

# vi /etc/X11/XF86Config-4

Find the line with

Driver "nv"

and change it to

Driver "nvidia"

(to edit in vi, press the 'insert' key. to stop editing, press 'Esc'. When
you are done, press :wq to write and quit.)

8. Reboot your computer (type 'reboot' at the console) and it should come
up with the NVidia driver.
Go to the top of the page
 
+Quote Post
veris2040
post Mar 27 2004, 04:11 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 8
Joined: 7-January 04
Member No.: 2,094



Something nobody ever says when they fix their Nvidia drivers for Linux:

If your Nvidia Card is AGP need to configure your XF86Config-4 to accomodate this:

In the same section where you changed "nv" to "nvidia" create a new option:

Option "NvAGP" "3"

this will allow you to gain the 3d acceration from the card

another Option of significance:

Option "NoLogo" "1"

This will allows you to turn off the Nvida Logo when X-Server starts up on your computer
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 15th December 2017 - 02:39 PM