Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
2 Pages V   1 2 >  
Reply to this topicStart new topic
> Sendmail Problem
Robert83
post Mar 1 2004, 08:02 AM
Post #1


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

I've found where I need to add the line to make sendmail use smtp.stcable.co.yu...

[root@WindowsXP mail]# m4 /etc/mail/sendmail.mc > /etc/mail/sendmail.cf
/etc/mail/sendmail.mc:10: m4: Cannot open /usr/share/sendmail-cf/m4/cf.m4: No such file or directory


but when I do this it report back this error? any ideas?

[sendmail is running]


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 1 2004, 08:11 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Problem solved...


If anyone encounters the same problems

get sendmail-cf

yum install sendmail-cf

apt-get install sendmail-cf

[for some reason it wasn't installed with sendmail on my computer]

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 1 2004, 08:16 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



You are faster than me biggrin.gif .... I posted to your other thread how to do this... laugh.gif (well not the sendmail-cf part)


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 1 2004, 08:18 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



smile.gif I was just confused for a while, then found the solution ... smile.gif smile.gif

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 1 2004, 08:34 AM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Now this is something new, I've did it everything, sendmail is runing fine...

now here it is,
I've added a mailto = somebody@xxxxxxxx.co.yu to every rulename "xxxxxxxx".
Like this
(
rulename = "xxxxxxxxxxxxxx",
severity = $(SIG_HI),
emailto = somebody@xxxxxxx.co.yu
)

and I've edited /root/.mc/ini changed one line value from 1 to 0 just to see what happens...

well tripwire -m c [and also tripwire --check] reports violation [good], but no mail is sent, where can I find the sendmail.log file or something like that , to see what happens actualy?


in tripwire config file
the SENDMAIL LINES look like this

MAILMETHOD = SENDMAIL
MAILPROGRAM = /usr/sbin/sendmail -oi -t


what could be wrong?

and one more thing, what do I have to do to see who made those modifications ?, I mean not just what was modified, but also who made them, which user , from what IP etc...


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 1 2004, 08:57 AM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



the command line:

sendmail -oi -t

should work .... try this:

sendmail -oi -t email@youraddress.com

(substitute your actual e-mail address, then press enter ... then type a couple words, then press enter again...then press Ctrl-D...it should send you the email) .... if not, the log is:

/var/log/maillog


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 1 2004, 09:12 AM
Post #7


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



You might want to create a sperate log with auth information (logins) and remove it from the /var/log/messages file so you have a single log that shows logins seperately ....

If you do want to do this, here are the steps:

Edit the file /etc/syslog.conf

find the line that looks similar to this:

CODE
*.info;mail.none;news.none;authpriv.none;cron.none            /var/log/messages


add ;auth.none to the end of the first section so mine would look like this:

CODE
*.info;mail.none;news.none;authpriv.none;cron.none;auth.none            /var/log/messages


Add another line that looks like this:
CODE
auth.*                                                  /var/log/auth


save the /etc/syslog.conf file .... then edit the file /etc/logrotate.d/syslog

find the line that looks similar to this (it is the first line in my file) (it is one line, in case it wraps in this post):

CODE
/var/log/messages /var/log/secure /var/log/maillog /var/log/spooler /var/log/boot.log /var/log/cron {


and add /var/log/auth to it (similar to this)

CODE
/var/log/messages /var/log/auth /var/log/secure /var/log/maillog /var/log/spooler /var/log/boot.log /var/log/cron {


then restart the syslog with:

/etc/init.d/syslog restart

and all login info will now be logged to /var/log/auth
-----------------
That is where you will look (/var/log/auth ... or /var/log/messages if you don't auth to another file) to see who was logged in during any changes.....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 1 2004, 09:19 AM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

... while talking to mail.teleportgroup.net.:
>>> DATA
<<< 550-Verification failed for <root@WindowsXP.zt2f48X>
<<< 550-Unrouteable address
<<< 550 Sender verify failed
550 5.1.1 <somebody@teleport.co.yu>... User unknown
<<< 503 valid RCPT command must precede DATA

what can I do ? [I've told sendmail to use smtp.stcable.co.yu]

I've isued the command sendmail -oi -t somebody@teleport.co.yu, but this comes out above....in the /var/spool/mail/root

what is wrong?

Sincerely
Robert B

ps.: thanks for that auth part! smile.gif


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 1 2004, 09:40 AM
Post #9


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

As I found out mail.teleport.co.yu checks if the sender is valid...or something, so :

is there a way to somehow make root@blablabla turn into somebody@stcable.co.yu ?
how?


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 1 2004, 12:54 PM
Post #10


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



You can do that .... OR ... you can just let the firewall send the message directly by taking out the smtp.stcable.co.yu ... the Firewall will connect to the e-mail server and you should get the e-mail.

just put dnl back infront of the line in sendmail.mc and remake the sendmail.cf....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 1 2004, 01:12 PM
Post #11


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

I've did it just like you told me to, but no mail on somebody@teleport.co.yu...
the following thing is in the /var/log/mail.log

Mar 1 19:01:16 WindowsXP sendmail[3823]: i21K1E4L003821: to=<somebody@teleport.co.yu>, ctladdr=<root@WindowsXP.zt2f48X> (0/0), delay=00:00:02, xdelay=00:00:02, mailer=relay, pri=30298, relay=smtp.stcable.co.yu [62.108.117.6], dsn=2.0.0, stat=Sent (Ok: queued as 7F246C9C6)

Sincerely
Robert B

ps.: maybe teleport is still denying because of root@WindowsXP.zt2f48X?


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 1 2004, 02:50 PM
Post #12


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



That is the problem .... maybe set the default gateway of the firewall as the eth0 ip address (the external address)....
If that doesn't work, try this

In the sendmail.mc change this (change the other setting for relay back on):

dnl MASQUERADE_AS(`mydomain.com')dnl

to this:

MASQUERADE_AS(`stcable.co.yu')dnl

and this:

dnl MASQUERADE_DOMAIN(localhost.localdomain)dnl

to this:

MASQUERADE_DOMAIN(`localhost.localdomain')dnl (<--If you changed the LOCAL_DOMAIN(`localhost.localdomain')dnl line then use what you used as `localhost.localdomain' for LOCAL_DOMAIN in MASQUERADE_DOMAIN)

------------------------
edit the file /etc/mail/genericstable and add:

root somebody@stcable.co.yu
-----------------------
edit the file /etc/mail/virtusertable and add

somebody@stcable.co.yu root

(use a tab key between the names and the addresses in virtusertable and genericstable)
-----------------------
See Masquerading and Relaying and Virtual Hostingfor details.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 1 2004, 04:36 PM
Post #13


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Thank you again for you're help!!! smile.gif

I will try this imedialty.

Sincerly
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 1 2004, 05:20 PM
Post #14


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



still nothing sad.gif(

I've tried chaging the gateway [the default route, I hope I did this right], to the external IP, wich didn't go well, no internet after etc...so I've left it at 217.xxx.xxx.1 [as it is the default gw for my 217.xxx.xxx.17].

This is how my sendmail.mc looks like :
----------------------------------------------------------------------------------------------------------------------------------------------------------------------
divert(-1)dnl
include(`/usr/share/sendmail-cf/m4/cf.m4')dnl
VERSIONID(`setup for Red Hat Linux')dnl
OSTYPE(`linux')dnl
define(`SMART_HOST',`smtp.stcable.co.yu')dnl
define(`confDEF_USER_ID',``8:12'')dnl
define(`confTO_CONNECT', `1m')dnl
define(`confTRY_NULL_MX_LIST',true)dnl
define(`confDONT_PROBE_INTERFACES',true)dnl
define(`PROCMAIL_MAILER_PATH',`/usr/bin/procmail')dnl
define(`ALIAS_FILE', `/etc/aliases')dnl
define(`UUCP_MAILER_MAX', `2000000')dnl
define(`confUSERDB_SPEC', `/etc/mail/userdb.db')dnl
define(`confPRIVACY_FLAGS', `authwarnings,novrfy,noexpn,restrictqrun')dnl
define(`confAUTH_OPTIONS', `A')dnl
define(`confTO_IDENT', `0')dnl
FEATURE(`no_default_msa',`dnl')dnl
FEATURE(`smrsh',`/usr/sbin/smrsh')dnl
FEATURE(`mailertable',`hash -o /etc/mail/mailertable.db')dnl
FEATURE(`virtusertable',`hash -o /etc/mail/virtusertable.db')dnl
FEATURE(redirect)dnl
FEATURE(always_add_domain)dnl
FEATURE(use_cw_file)dnl
FEATURE(use_ct_file)dnl
FEATURE(local_procmail,`',`procmail -t -Y -a $h -d $u')dnl
FEATURE(`access_db',`hash -T<TMPF> -o /etc/mail/access.db')dnl
FEATURE(`blacklist_recipients')dnl
EXPOSED_USER(`root')dnl
FEATURE(`accept_unresolvable_domains')dnl
LOCAL_DOMAIN(`WindowsXP.zt2f48X')dnl
MASQUERADE_AS(`stcable.co.yu')dnl
MASQUERADE_DOMAIN(WindowsXP.zt2f48X)dnl
MAILER(smtp)dnl
MAILER(procmail)dnl
---------------------------------------------------------------------------------------------------------------------------------------------------------------------
when I type hostname in console it returns : WindowsXP.zt2f48X so I suppose that comes instead of localhost.localdomain in both those lines above.[in console like this : [root@WindowsXP root] # ,but I guess it's the same without the domain part].

genericstable [wich I've created manualy , since there was none] :
root somebody@stcable.co.yu

virtusertable looks like this :
somebody@stcable.co.yu root

what did I miss? is there hope to get this thing going?

Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 2 2004, 07:12 AM
Post #15


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Try this:
Add this line at the bottom of the defines:

define(`GENERICS_DOMAIN_FILE',`/etc/mail/generics-domains')dnl

add these lines after the line {FEATURE(`virtusertable',`hash -o /etc/mail/virtusertable.db')dnl}:

FEATURE(`genericstable',`hash -o /etc/mail/genericstable.db')dnl
FEATURE(`masquerade_envelope')dnl
--------------------------------------------------
For {LOCAL_DOMAIN(`WindowsXP.zt2f48X')dnl} use the hostname (and domainname if you gave it one) of the Firewall (that you set via hostname) and replace WindowsXP.zt2f48X with the local hostname.domainname.

use 2 MASQUERADE_DOMAIN entries ... one for the local hostname.domainname that you named the machine ... one for WindowsXP.zt2f48X, like this:

MASQUERADE_DOMAIN(`hostname.domainname')dnl
MASQUERADE_DOMAIN(`WindowsXP.zt2f48X')dnl

(also in the MASQUERADE_DOMAIN entires make sure to use the ` and the ' ..... (the ` is the key beside 1 ... the ' in the key beside the enter key on my qwerty US keyboard)

Also, get rid of EXPOSED_USER(`root') ... that means the user root won't get remapped using the virtual addresses.....

When you get done .. all root e-mails should go to somebody@stcable.co.yu

so it should look like this:
CODE
divert(-1)dnl
include(`/usr/share/sendmail-cf/m4/cf.m4')dnl
VERSIONID(`setup for Red Hat Linux')dnl
OSTYPE(`linux')dnl
define(`SMART_HOST',`smtp.stcable.co.yu')dnl
define(`confDEF_USER_ID',``8:12'')dnl
define(`confTO_CONNECT', `1m')dnl
define(`confTRY_NULL_MX_LIST',true)dnl
define(`confDONT_PROBE_INTERFACES',true)dnl
define(`PROCMAIL_MAILER_PATH',`/usr/bin/procmail')dnl
define(`ALIAS_FILE', `/etc/aliases')dnl
define(`UUCP_MAILER_MAX', `2000000')dnl
define(`confUSERDB_SPEC', `/etc/mail/userdb.db')dnl
define(`confPRIVACY_FLAGS', `authwarnings,novrfy,noexpn,restrictqrun')dnl
define(`confAUTH_OPTIONS', `A')dnl
define(`confTO_IDENT', `0')dnl
define(`GENERICS_DOMAIN_FILE',`/etc/mail/generics-domains')dnl
FEATURE(`no_default_msa',`dnl')dnl
FEATURE(`smrsh',`/usr/sbin/smrsh')dnl
FEATURE(`mailertable',`hash -o /etc/mail/mailertable.db')dnl
FEATURE(`virtusertable',`hash -o /etc/mail/virtusertable.db')dnl
FEATURE(`genericstable',`hash -o /etc/mail/genericstable.db')dnl
FEATURE(`masquerade_envelope')dnl
FEATURE(redirect)dnl
FEATURE(always_add_domain)dnl
FEATURE(use_cw_file)dnl
FEATURE(use_ct_file)dnl
FEATURE(local_procmail,`',`procmail -t -Y -a $h -d $u')dnl
FEATURE(`access_db',`hash -T<TMPF> -o /etc/mail/access.db')dnl
FEATURE(`blacklist_recipients')dnl
dnl EXPOSED_USER(`root')dnl
FEATURE(`accept_unresolvable_domains')dnl
LOCAL_DOMAIN(`hostname.domainname')dnl
MASQUERADE_AS(`stcable.co.yu')dnl
MASQUERADE_DOMAIN(`hostname.domainname')dnl
MASQUERADE_DOMAIN(`WindowsXP.zt2f48X')dnl
MAILER(smtp)dnl
MAILER(procmail)dnl

(You replace each instance of hostname.domainname with the actual value that you named the Whitebox firewall that is in /etc/sysconfig/network)

Also, the somebody@stcable.co.yu is going to be the outgoing name on root e-mails ... it has to be a valid account at stcable.co.yu that can send mail....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 2 2004, 07:53 AM
Post #16


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Hi,

IT WORKS!!!! THANK YOU!!!!!! smile.gif

but! smile.gif smile.gif smile.gif

What did I do wrong , I get the e-mail but from root@stcable.co.yu [not a SO BIG problem], howto make that then turn into somebody@teleport.co.yu, where should I search for the mistake?


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 2 2004, 08:05 AM
Post #17


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



now this is starting to be unbeliavable smile.gif smile.gif

Hi,

So sendmail is working ok now, but tripwire won't send a mail to me even if I change some critical files....

What could be wrong?

the config file for tripwire looks like this ...

ROOT =/usr/sbin
POLFILE =/etc/tripwire/tw.pol
DBFILE =/var/lib/tripwire/$(HOSTNAME).twd
REPORTFILE =/var/lib/tripwire/report/$(HOSTNAME)-$(DATE).twr
SITEKEYFILE =/etc/tripwire/site.key
LOCALKEYFILE =/etc/tripwire/$(HOSTNAME)-local.key
EDITOR =/bin/vi
LATEPROMPTING =false
LOOSEDIRECTORYCHECKING =false
MAILNOVIOLATIONS =true
EMAILREPORTLEVEL =3
REPORTLEVEL =3
MAILMETHOD =SENDMAIL
SYSLOGREPORTING =false
MAILPROGRAM =/usr/sbin/sendmail -oi -t


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
hughesjr
post Mar 2 2004, 08:06 AM
Post #18


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



I forgot to tell you to make the map hashes ...

from within the /etc/mail directory ... use the command

makemap hash genericstable < genericstable

and

makemap hash virtusertable < virtusertable


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Robert83
post Mar 2 2004, 08:08 AM
Post #19


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



Thank's smile.gif

Also check if you can that thing about my tripwire e-mail problems please smile.gif


Sincerely
Robert B


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post
Robert83
post Mar 2 2004, 08:15 AM
Post #20


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,439
Joined: 3-January 04
From: Germany
Member No.: 2,069



[I did that makemap part, but it's still is root@stcable.co.yu] hm? something else?


--------------------
Robert Becskei
robert83@linuxhelp.net
--------------------
May the source be with us!
--------------------
AMD X2-3800 @ 2400Mhz
2048MB DDR 400Mhz
DFI Lanparty UT4 NF4 ULTRA-D
GeForce 7800GT
250GB+250GB
Pioneer DVD-RW
17inch Samsung Syncmaster 757NF
WinXP Pro (SP2)/ CentOS 4.3
--------------------
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th December 2017 - 12:12 AM