Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Su -, Cannot SU - when using telnet
fmagoufis
post Dec 4 2002, 12:44 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 16
Joined: 4-December 02
From: Boston
Member No.: 214



All of a sudden, i cannot use the su - comman. When i run it and type in the correct superuser password, it says password incorrect.

Why wink.gif
Go to the top of the page
 
+Quote Post
Joey
post Dec 4 2002, 12:51 PM
Post #2


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



Out of sheer curiousity, why on earth are you using telnet?

SSH is a wonderful thing.

http://www.ssh.org
http://www.openssh.org
Go to the top of the page
 
+Quote Post
fmagoufis
post Dec 6 2002, 01:57 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 16
Joined: 4-December 02
From: Boston
Member No.: 214



Even if i use ssh to connect i still cannot do a su -. The server is at my work in another office.

Any help would be appreciated.
Go to the top of the page
 
+Quote Post
Corey
post Dec 6 2002, 03:12 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



Well, I'm not sure with telnet (because I use mostly SSH), but you may have to set telnet up to allow for remote root login. I know with ssh, you have to set it in the config file in order for you to ssh -l root .


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
fmagoufis
post Dec 10 2002, 02:57 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 16
Joined: 4-December 02
From: Boston
Member No.: 214



i tried fixing the config file, but anytime i run su - , I get wrong password.
Go to the top of the page
 
+Quote Post
chrisw
post Dec 10 2002, 04:15 PM
Post #6


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



It could be that you are not in the group: wheel
this group is used for people who can su -
to root. Therefore if you are not in the group wheel
you can not su - to root. Check the group file
and see if there is a list of names besides root,
if root is even listed..and if there is a list of
user names...see if you are in that list....if not
you wont be able to su to root
if you are not in the list try getting someone
who can su to root and add you to the group


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
fmagoufis
post Dec 11 2002, 11:25 AM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 16
Joined: 4-December 02
From: Boston
Member No.: 214



i am on the group. what next?
could it be a rights issue?
Go to the top of the page
 
+Quote Post
chrisw
post Dec 11 2002, 01:42 PM
Post #8


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



if you are in the group wheel then
you should be able to su - to root

check to see if the file "su" which
is in /etc/pam.d/
directory has the group set to wheel
just look for a line that has
the following

10
- or -
wheel

if so,
i dont know of anything off hand that is
keeping you from su'ing to root.


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
fmagoufis
post Dec 12 2002, 01:30 PM
Post #9


Whats this Lie-nix Thing?
*

Group: Members
Posts: 16
Joined: 4-December 02
From: Boston
Member No.: 214



everything looks good.

Where to look next?
Go to the top of the page
 
+Quote Post
chrisw
post Dec 12 2002, 05:48 PM
Post #10


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



im not sure where to look next....
you sure you are typing in the correct
password for root?


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
fmagoufis
post Dec 13 2002, 10:09 AM
Post #11


Whats this Lie-nix Thing?
*

Group: Members
Posts: 16
Joined: 4-December 02
From: Boston
Member No.: 214



absolutely typing in the correct password.
Go to the top of the page
 
+Quote Post
Corey
post Dec 13 2002, 11:21 AM
Post #12


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



The only other thing I can think of is, try to type your password just in plain site on the command line before you "su -". Make sure that it appears right there, the only thing I can think of is that your keyboard is mapped wrong through your telnet(ssh) program. Have you tried just typing "su" rather then "su -" ? As well, have you tried to enable remote root login, and just logged in as root rather then su'in?


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
fmagoufis
post Dec 22 2002, 01:58 PM
Post #13


Whats this Lie-nix Thing?
*

Group: Members
Posts: 16
Joined: 4-December 02
From: Boston
Member No.: 214



how do I enable remote root login?
Go to the top of the page
 
+Quote Post
chrisw
post Dec 22 2002, 10:23 PM
Post #14


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



if you are running redhat
you enable remote root login by editing the sshd.config file
in /etc/sshd folder

change permit root login from no to yes

the save the file...then restart ssh

by typing

/etc/rc.d/init.d/sshd restart


--------------------

Chris W.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 12:33 AM