Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Problem With Htaccess, I create it in htdocs, but doesn't work
Termina
post Feb 19 2004, 09:16 PM
Post #1


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



/usr/local/apache2/htdocs is where my website files are.
This is what my ".htaccess" file looks like.

CODE
AuthUserFile /usr/local/apache2/htdocs/.htpasswd
AuthGroupFile /dev/null
AuthName termina.kicks-ass.net secret
AuthType Basic

<Limit GET POST>
require valid-user
</Limit>


I have an ".htpasswd" file that looks like this (simply for testing):
CODE
admin:fOPT7EqSvegho


my httpd.conf file has this line, so it SHOULD work.

CODE
# AllowOverride controls what directives may be placed in .htaccess files.
AccessFileName .htaccess



I'm getting kind of frustrated here. XD

If it helps, I'm running Knoppix Debain (kernel 2.4), apache2, php and mysql as well. ;_; htaccess and htpasswd are in the same dir

Any help would be appreciated!


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post
chrisw
post Feb 20 2004, 12:15 AM
Post #2


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



you need to change
in your conf file for apache
the following line

look for a line that says
allowoveride none

and change it to

allowoveride authconfig


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
Termina
post Feb 20 2004, 02:39 PM
Post #3


RMS is my Hero
******

Group: Support Specialist
Posts: 862
Joined: 18-February 04
From: Wisconsin
Member No.: 2,404



I get an internal service error when I do that. O_o

Anyone else have any idea?


--------------------
*Points finger at the author above him* They're a witch! Burn them!
---
Vist my website!
Join me in IRC! Server: st0rage.org Channel: #UnhandledExceptions
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 10:33 AM