Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Laptop Pretty Much Dead, almost dead after linux install
OVerLoRDI
post Feb 15 2004, 05:12 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 15-February 04
Member No.: 2,380



Ok here i go,
Decided hey im gonna try linux again
I went and downloaded the mandrake 10.0b2 isos someone recommended them. I had a partition earlier on my laptop from when i tried mandrake 9.1 i had deleted that partition and reformatted it to ntfs. In windows i deleted that partition. Threw in the first linux boot CD, and restarted my computer. Installation went happy and easily. I chose set up lilo on MBR. rebooted computer, lilo booted up i selected linux, linux started loading and then generated this error: (note: the error might not be exactly correct i wrote it down rather quickly)

Enabling IO-APIC
TIMER: vector=0x31 pin1=2 pin2=0
MP-BIOS bug: 8254 timer not connected to IO-APIC
trying to set up timer (irq0) through the 8254A ....
(found pin 0) ... failed
trying to set up timer as Virtual Wire IRQ ... failed
trying to set up timer as ExtINT IRQ ... failed sad.gif (yes it did have the sad face)
Kernel Panic

from my understandin of that junk, i had some bad irq settings so i went to my bios config menu and foudn no controls for IRQs. So i used the restore defaults commands. Tried to boot linux and it said
CPU: 0
Where it used to say pentium 4 2.4ghz, boom another kernel panic. I then restarted the computer lilo booted fine, i tried to boot windows and got missing or corrupt NTLDR. Which i found out that means the MBR is corrupt, but how can it be when lilo installed on the MBR is working fine. So from there i tried to boot off a windows CD to write a new MBR. It read the CD and said press any key to boot from CD. I hit enter, it said windows is inspecting your hardware configuration and crashed. So i tried the linux CD, linux cd comes up i hit enter it starts to load and crashes. I then thought well cmos must still have bad irq values. Out of desperation i took apart my laptop found the cmos battery, removed it put the laptop back together and turned it on. Laptop booted fine gave me error cmos date/time not set varifying that the cmos had been cleared. I set the date and time. tried to boot linux, same thing, tired windows, same thing, tried booting from windows boot CD and linux Boot Cd, same thing. I have no floppy drive. Where do i go from here? Any help woudl be appreciated. This problem should be fixable, installing an operating system shoudln't render a computer useless.

OVerLoRDI
Go to the top of the page
 
+Quote Post
hughesjr
post Feb 15 2004, 08:12 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



If you read through your post, it wasn't the installing of an OS, but the resetting of the CMOS values to default that messed up your laptop to the point where it can't boot in either OS (and messing with BIOS values can cause major problems) ... there are normally 2 types of defaults .. the bios defaults and the installation defaults. The BIOS defaults are not necessarily good for every installtion of the BIOS.

When you highlight a bios option and press help, does it give you the default value? (Or tell you the default values in a sperate window)? ... if so is there a setup and default value listed ... if so, use the setup values.

It seems that at least the hard drive is no longer recognized...and there may be some other problems with power management and the like.

-----------------
When using the mandrake CD, press F1 and type:

linux noapic

When booting from the hard drive into linux, press Esc at the LILO select screen and type:

linux noapic

If you get into linux, edit the file /etc/lilo.conf and add noapic to all the kernel append lines....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
OVerLoRDI
post Feb 15 2004, 03:10 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 15-February 04
Member No.: 2,380



I will try what you told me, but i didn't clear the cmos values till i verified that both windows and linux would not boot or any recovery CDs. Sorry if my post wasnt' clear enough.

Thanks
Go to the top of the page
 
+Quote Post
OVerLoRDI
post Feb 15 2004, 03:13 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 15-February 04
Member No.: 2,380



no go, i get:
Code: Bad EIP value
<0>Kernel panic: Attempted to kill init!

any ideas?
Go to the top of the page
 
+Quote Post
OVerLoRDI
post Feb 15 2004, 03:16 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 15-February 04
Member No.: 2,380



GOOD NEWS! i have it booting the mandrake installtion disc! where should i go from here?

update:reinstalling mandrake did not work.
Go to the top of the page
 
+Quote Post
OVerLoRDI
post Feb 15 2004, 05:23 PM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 15-February 04
Member No.: 2,380



GOOD NEWS!!! linux is booting!!! Sadly windows still gives me NTRDL missing error.
Go to the top of the page
 
+Quote Post
hughesjr
post Feb 15 2004, 06:36 PM
Post #7


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



If the partition you deleted at the start was the first partition on the primary master drive, that is where Windows XP puts the ntldr, ntdetect.com, boot.ini, msdos.sys and io.sys (even if XP is on another partition).

If that is the case, you can copy those files from another install onto your actual XP partition and it should then boot...

If this is your problem, here is a copy of the files you need (in a winzip file), unzip them to a floppy and if you can now get the XP cd to boot, you can copy the files using the recovery console in WinXP. They belong in the root of you XP Partition.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
OVerLoRDI
post Feb 16 2004, 03:19 AM
Post #8


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 15-February 04
Member No.: 2,380



Thank you for your help, i got linux booting using a non beta kernel. then backed up everything on to my xbox. Deleted all partitions on the drive and start over. It's all working fine.

OVerLoRDI
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 14th December 2017 - 09:49 PM