Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Could It Be A Memory Leak?, strange memory use
albustansintra
post Feb 13 2004, 09:56 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 13
Joined: 13-February 04
Member No.: 2,373



hello, Im pretty new to the linux scene, so bear with me please..

I have two athlon PC's running RH9 with full updates including latest kernel from up2date.
Both Pc's have what I consider to be an unusuall memory consumption!!

When I boot up, I run "top" and see that out of 754MB total physical RAM I have +- 200MB used, If I leave it for a couple of hours the used RAM aparently rised, because I do "top" again and have 452 or 500 MB used. That is with X running Gnome.
Its not a critical problem because the PC runs just fine, I havent noticed it rise over the 754MB mem use, but I find it strange because after a reboot its back to 200MB again and the running services are exactly the same.
I suspect that this could this be a memory leak? so I tried the memory profile program that comes with RH9, but never figure out how to use it properlly. Memory profile as it seems checks for leaks but (correct me if I'm wrong) you have to check process by process.
Does anybody know of memory leak detection programs that could detect which of my processes is causing the leak?
Or better yet, is it normal for RH9 to occupy my free RAM like it does on my PCs.
Don't hit me,.. Im still new at this unsure.gif

Any help or personal opinions welcome!
Go to the top of the page
 
+Quote Post
hughesjr
post Feb 13 2004, 11:24 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



This is not a problem ... linux does it on purpose. It is mostly disk cache and other things that are low priority and will be dumped if the memory is required by something else ... here is my output:

CODE
22:21:52  up 2 days, 21:46,  2 users,  load average: 0.05, 0.05, 0.06
78 processes: 77 sleeping, 1 running, 0 zombie, 0 stopped
CPU states:  cpu    user    nice  system    irq  softirq  iowait    idle
          total    1.5%    0.0%    0.0%   0.0%     0.0%    0.2%   98.1%
          cpu00    0.3%    0.0%    0.0%   0.0%     0.0%    0.0%   99.6%
          cpu01    4.7%    0.0%    0.0%   0.0%     0.0%    0.1%   95.0%
          cpu02    0.3%    0.0%    0.1%   0.0%     0.0%    0.0%   99.4%
          cpu03    0.7%    0.0%    0.0%   0.0%     0.0%    0.7%   98.4%
Mem:  1028464k av,  961384k used,   67080k free,       0k shrd,   99496k buff
                   379592k actv,  501196k in_d,   13548k in_c
Swap: 1052248k av,    0k used, 1052248k free                  716428k cached


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
albustansintra
post Feb 14 2004, 10:34 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 13
Joined: 13-February 04
Member No.: 2,373



Ok, then. That's good news.

I must admit, it sounds a a bit strange... But your output is very similar to mine, and the system runs just fine, never going over physical mem limit !
I was having a hard time understanding which processes were using up all the RAM. The sum of all my processes doesn't come close to the anounced memory use.

thanks alot, cheers!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 09:14 PM