Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Parallel Port Conflict, Trying to set up parallel port joysticks
glibdud
post Feb 6 2004, 02:45 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 6-February 04
Member No.: 2,318



Greetings. I think this is a fairly simple problem, and I hope it has a solution short of rebuilding the kernel. smile.gif

I'm trying to get a couple of old-school Nintendo controllers hooked up via the parallel port as described in the joystick-parport.txt document shipped with the kernel (2.4.20). I think I'm almost there... For now I'm passing the 'gc=...' line to the kernel at the LILO prompt, but it appears lp0 gets a hold of the parallel port just before the joystick driver does. From my syslog:

CODE
Feb  5 19:22:16 pollux kernel: parport0: PC-style at 0x378 [PCSPP,TRISTATE]
...
Feb  5 19:22:16 pollux kernel: lp0: using parport0 (polling).
Feb  5 19:22:16 pollux kernel: parport0: cannot grant exclusive access for device gamecon
Feb  5 19:22:16 pollux kernel: gamecon.c: parport busy already - lp.o loaded?


lp0 doesn't need to be messing with the parallel port at all. How can I disable this? (To the best of my recollection, all relevent kernel options are compiled in, rather than built as modules... if any specific knowledge is needed, I can look it up.)

Thanks,
-David Murphy
Go to the top of the page
 
+Quote Post
glibdud
post Feb 7 2004, 08:19 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 6-February 04
Member No.: 2,318



Follow-up: I've done some more research, and thought I had found the answer to my question. A tip from a help dialog in the kernel 'make menuconfig' led me to the file drivers/char/lp.c, which says that when parallel printer support is compiled into the kernel (which it is, in my case), then passing 'lp=off' to the kernel should do the trick. Sadly, this appears not to be the case. I passed 'lp=off gc=..." at the LILO prompt, and I still got the same messages on bootup as above: lp0 still grabs onto the port.

Any other ideas?

Thanks,
-David Murphy
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th December 2017 - 03:51 PM