Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Redhat 9 Locks Up, locks up during the boot
Bobje
post Feb 6 2004, 12:50 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 6-February 04
Member No.: 2,310



hello I just installed Redhat 9.0 on one of my computers. It orginally had windows 2000, but I had redhat delete all partitions and start its own through the auto setting. Then I could not get it to do the graphical install. I did the text install and it worked. After the reboot I was able to select teh video driver and set the time zone. Once I complete this it locks up and the monitor goes into power saving mode. I have even tried to let it go for about 10-15 min to see if it would come back, but no joy. I used the Lilo boot, should i use Grub instead? any help would be greatly appreciated.
Go to the top of the page
 
+Quote Post
Jim
post Feb 6 2004, 02:10 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



The problem isn't with Lilo or grub, the issues is most likely with your video card.

What kind of computer is it and more importantly what video card do you have?

Do you have the most current kernel available for Redhat?

Try booting no graphically and see what happens, to do that follow these instructions

At the GRUB screen select the version you want to boot to (in the case probably Red Hat 9)
Press "E" to edit the boot file.
Press "E" again than add the line
CODE
init3


at the end of the file, than press B to boot the edited line.

This should bring you through the boot proccess and get you to a login prompt. If that works that we know that it's for sure an issue with your graphics system wich probably means it is an issue with your video card. You will be able to install the right drivers for your system from that line ounce we figuer out what the right drivers are.

Just to see, try typing the cmmand "startx" at the prompt to see what happens if you try to start an X window system.

Try that and see how it goes.


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post
Bobje
post Feb 6 2004, 07:46 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 6-February 04
Member No.: 2,310



Thanks for the help. I tried what you suggested, but it did not work. I did change the video card out ( it was an Geforce FX 5200) and put in a geforce 2 GTS, and that seemed to fix it. Thanks for pointing me in the right direction. I will probably have many more questions as this is the first time I have tried Linux.
Go to the top of the page
 
+Quote Post
hughesjr
post Feb 8 2004, 08:39 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



I use a gforce 5200 FX with linux ... If you want to use that card, you have to download and install the Nvidia binary drivers .... (If you have broadband internet this should be quick ... with dialup only I wouldn't recommend it)

It's not that hard to do ...

First, I would update the RH 9 OS with all errata updates. With the restrictions RedHat as placed on up2date lately (you only get one demo account, can't change it between PCs, etc.) I would recommend apt from fresh rpms.

To install apt ... go HERE and download the apt-0.5.5cnc6-fr1.i386.rpm (first) file.

Install it with the command (as root from a terminal):

rpm -Uvh apt-0.5.5cnc6-fr1.i386.rpm

import the freshrpms GPG key (this step is optional, But I recommend it):

CODE
rpm --import http://freshrpms.net/packages/RPM-GPG-KEY.txt


Now you can get the latest security patches and updates released with the following commands:

apt-get update
apt-get dist-upgrade


Next, you need to upgrade to the latest kernel ... I normally I do this manually ... download one of these files:

Latest AMD Althon XP Kernel

Latest Intel Pentium 2 or Higher Kernel

Install the latest kernel via the command:

rpm -Uvh kernel-2.4.20-28.9.i686.rpm (or rpm -Uvh kernel-2.4.20-28.9.athlon.rpm if using the Athlon).

After this is done ... you need to install the kernel-source package:

You can do this with the following command:

apt-get install kernel-source#2.4.20-28.9
------------------------
I would recommend that you do all the above if you have a fast (broadband) internet connect, reguardless of whether you upgrade your nvidia drivers...
-----------------------
Latest Nvidia driver install

Download the latest nvidia drivers for linux ... currently the latest driver is NVIDIA-Linux-x86-1.0-5336-pkg1.run

(You can always get the latest GeForce Nvidia driver by going to this page and selecting Graphics Driver in box 1 .... GeForce and TNT2 in box 2 ... Linux IA32 in box 3 and then pressing go.)

Download the driver ....

then in a terminal (as root, from within the directory where you put the downloaded file) issue the following command:

chmod 755 NVIDIA-Linux-x86-1.0-5336-pkg1.run

Now ... shift to none X mode .... with the command:

init 3

If you are not at the login prompt, press Enter ... login as root

Now install the driver with this command:

IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-5336-pkg1.run

Accept the agreement, Select "Yes" as the answer to all questions to install the driver.

Edit the file /etc/X11/XF86Config (you can do this either via a console editor like vi, pico, joe,or nano ... or type init 5 and login as root and use gedit.

Once you are editing the XF86Config file ... remark out any reference to dri or GLcore ... (in any combination of upper or lower case letters) by placing a # at the brginning of that line .... like this:
CODE
#        Load  "dri"
#        Load  "GLcore"


In the section where all the loads are add (if it's not alread there):

load "glx"

In the driver section...change:

Display "xxxxxx"

to

Display "nvidia"

Shutdown Linux and change back to your GeForce FX 5200 card and startup the system....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th October 2017 - 02:20 AM